summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoyan Ding <boyan.j.ding@gmail.com>2015-07-21 23:43:54 +0800
committerMartin Peres <martin.peres@linux.intel.com>2015-11-17 17:26:20 +0200
commit6bd9ba7d07490059024d16ba32fafa1c5bb239ee (patch)
tree55b87a823566ebab87d6097c9cfc019e2f2a882c /configure.ac
parent252b143e9e8ca0b98143c237f14cb0b548ffd510 (diff)
loader: Add dri3 helper
v2: From Martin Peres - Try to fit in the 80-col limit as much as possible v3: From Martin Peres - introduce loader_dri3_helper.la to avoid dragging the xcb dep everywhere (Kristian & Emil) - get rid of the width, height, dri_screen and is_different_gpu vfuncs (Kristian) - replace the create/destroy functions with init/fini for dri3 drawables - prefix static functions with dri3_ and exported ones with loader_dri3 (Emil) - keep the function definition consistent (Emil) Signed-off-by: Boyan Ding <boyan.j.ding@gmail.com> Signed-off-by: Martin Peres <martin.peres@linux.intel.com> Reviewed-by: Kristian Høgsberg <krh@bitplanet.net> Reviewed-by: Emil Velikov <emil.velikov@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3f15881a18e..9ea9ab22346 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1226,7 +1226,8 @@ xyesno)
if test x"$enable_dri3" = xyes; then
PKG_CHECK_EXISTS([xcb >= $XCB_REQUIRED], [], AC_MSG_ERROR([DRI3 requires xcb >= $XCB_REQUIRED]))
- dri_modules="$dri_modules xcb-dri3 xcb-present xcb-sync xshmfence >= $XSHMFENCE_REQUIRED"
+ dri3_modules="xcb-dri3 xcb-present xcb-sync xshmfence >= $XSHMFENCE_REQUIRED"
+ PKG_CHECK_MODULES([XCB_DRI3], [$dri3_modules])
fi
fi
if test x"$dri_platform" = xapple ; then