summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-03-06 16:54:57 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2015-03-11 23:28:25 +0000
commit39f90e6b9bb0c9c8b40abae2afde07587cd49010 (patch)
treef2f4b76b473326053370fe97a1e3c0795a705fd9 /configure.ac
parenta806df3f23cd5fadffbfe818f8c5af7e17205426 (diff)
configure: require pthreads for POSIX builds
This has been an implicit rule for building mesa for a long time. Let's make it official and just bail out at configure time. This way we can cleaning up some of our glx code. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Brian Paul <brianp@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2954f80b401..a3b0ebd6cf9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -658,6 +658,9 @@ mingw*)
;;
*)
AX_PTHREAD
+ if test "x$ax_pthread_ok" = xno; then
+ AC_MSG_ERROR([Building mesa on this platform requires pthreads])
+ fi
;;
esac
dnl AX_PTHREADS leaves PTHREAD_LIBS empty for gcc and sets PTHREAD_CFLAGS