summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKenneth Graunke <kenneth@whitecape.org>2015-07-06 11:04:19 -0700
committerKenneth Graunke <kenneth@whitecape.org>2015-07-06 13:40:16 -0700
commit128de6f6d7cd0eb5386dcc622afc6e28a8512e7f (patch)
treeec9c075b7d47ad38ec59b131fe92db651fdb45e3 /configure.ac
parent86a3557d7c95ac945eedf42ab095639b255c1bed (diff)
mesa: Add a MUST_CHECK macro for __attribute__((warn_unused_result)).
In the kernel, this is called __must_check; all our attribute macros in Mesa appear to be uppercase, so I went with that. Signed-off-by: Kenneth Graunke <kenneth@whitecape.org> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk> Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ea0f069cd31..d240c060573 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,6 +210,7 @@ AX_GCC_FUNC_ATTRIBUTE([format])
AX_GCC_FUNC_ATTRIBUTE([malloc])
AX_GCC_FUNC_ATTRIBUTE([packed])
AX_GCC_FUNC_ATTRIBUTE([unused])
+AX_GCC_FUNC_ATTRIBUTE([warn_unused_result])
AM_CONDITIONAL([GEN_ASM_OFFSETS], test "x$GEN_ASM_OFFSETS" = xyes)