summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2011-09-18 17:34:47 -0400
committerBrian Paul <brianp@vmware.com>2011-09-19 07:39:19 -0600
commitf534c1341347438ed7607b0afa12244df8f1cd0a (patch)
treeff0c83166b45e0fdf2385dfb05a37a742d8730af /configure.ac
parent75eb92fb28545bd57281e465c1dadf63b38ab55a (diff)
Remove unused APP_LIB_DEPS variable
Unused since removal of demos from the repository? Signed-off-by: Matt Turner <mattst88@gmail.com> Signed-off-by: Brian Paul <brianp@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 0 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index 9916a06a92f..a686a11aa19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -949,13 +949,6 @@ xyesyes)
fi
GL_LIB_DEPS="$GL_LIB_DEPS $SELINUX_LIBS -lm -lpthread $DLOPEN_LIBS"
GL_PC_LIB_PRIV="$GL_PC_LIB_PRIV $SELINUX_LIBS -lm -lpthread"
-
- # if static, move the external libraries to the programs
- # and empty the libraries for libGL
- if test "$enable_static" = yes; then
- APP_LIB_DEPS="$APP_LIB_DEPS $GL_LIB_DEPS"
- GL_LIB_DEPS=""
- fi
;;
xyesno)
# DRI-based GLX
@@ -1578,7 +1571,6 @@ if test "x$enable_glu" = xyes; then
else
GLU_LIB_DEPS=""
GLU_MESA_DEPS=""
- APP_LIB_DEPS="$APP_LIB_DEPS -lstdc++"
fi
fi
fi
@@ -1593,25 +1585,6 @@ AC_SUBST([GLU_PC_REQ_PRIV])
AC_SUBST([GLU_PC_LIB_PRIV])
AC_SUBST([GLU_PC_CFLAGS])
-dnl
-dnl Program library dependencies
-dnl Only libm is added here if necessary as the libraries should
-dnl be pulled in by the linker
-dnl
-if test "x$APP_LIB_DEPS" = x; then
- case "$host_os" in
- solaris*)
- APP_LIB_DEPS="-lX11 -lsocket -lnsl -lm"
- ;;
- cygwin*)
- APP_LIB_DEPS="-lX11"
- ;;
- *)
- APP_LIB_DEPS="-lm"
- ;;
- esac
-fi
-AC_SUBST([APP_LIB_DEPS])
AC_SUBST([PROGRAM_DIRS])
dnl