summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2011-04-26 11:56:02 +0100
committerJon TURNEY <jon.turney@dronecode.org.uk>2011-06-28 17:07:02 +0100
commitdb78643182dc39ed592dd8c2e5fc7c8eeb7316a1 (patch)
tree687b3eb8fc82c83d767473dd0e83fd2bb170a035 /configure.ac
parent560f76227ccc848390095414e93d199e588b0c92 (diff)
Don't use -fvisibilty=hidden on cygwin
All it's going to do is generate lots and lots and lots of 'warning: visibility attribute not supported in this configuration; ignored' warnings Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk> Reviewed-by: Dan Nicholson <dbn.lists@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74357a2e24c..7fbba7d62d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -189,6 +189,15 @@ if test "x$GXX" = xyes; then
CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"
fi
+dnl even if the compiler appears to support it, using visibility attributes isn't
+dnl going to do anything useful currently on cygwin apart from emit lots of warnings
+case "$host_os" in
+cygwin*)
+ VISIBILITY_CFLAGS=""
+ VISIBILITY_CXXFLAGS=""
+ ;;
+esac
+
AC_SUBST([VISIBILITY_CFLAGS])
AC_SUBST([VISIBILITY_CXXFLAGS])