summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Stellard <thomas.stellard@amd.com>2012-03-12 13:53:20 -0400
committerTom Stellard <thomas.stellard@amd.com>2012-06-01 11:28:09 -0400
commitc79e7668b205492f6e3a7e5d599f6eb6a9bd1eb9 (patch)
tree975d008f5cab378b3802b21481ead025e79deae4 /configure.ac
parent613323b2564babc1ecaac25a6cfd786b8c839315 (diff)
configure.ac: Add option for libclc path
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 06fc2de39bd..7ddd5fad118 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1620,6 +1620,14 @@ dnl
dnl OpenCL configuration
dnl
+AC_ARG_WITH([libclc-path],
+ [AS_HELP_STRING([--with-libclc-path],
+ [Path to libclc builtins library. Example: --with-libclc-path=\$HOME/libclc/])],
+ [LIBCLC_PATH="$withval"],
+ [LIBCLC_PATH=""])
+
+AC_SUBST([LIBCLC_PATH])
+
if test "x$enable_opencl" = xyes; then
if test "x$with_gallium_drivers" = x; then
AC_MSG_ERROR([cannot enable OpenCL without Gallium])