summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYounes Manton <younes.m@gmail.com>2011-07-14 12:22:20 -0400
committerYounes Manton <younes.m@gmail.com>2011-07-15 01:12:14 -0400
commitb97816ddeeda33215db073a0ac1aaabe98d2af68 (patch)
tree61f7f3c92e2399d26ccfe01d044f2299e942edcd /configure.ac
parent864eb844ffd52251acaafbe61290df6cde154ec8 (diff)
g3dvl: Build the right winsys dependencies when needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 15 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index c186240189b..b882b5d23c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -811,6 +811,7 @@ xyesyes)
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/xlib"
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS libgl-xlib"
GALLIUM_STATE_TRACKERS_DIRS="glx $GALLIUM_STATE_TRACKERS_DIRS"
+ HAVE_WINSYS_XLIB="yes"
;;
xyesno)
# DRI-based GLX
@@ -1548,12 +1549,6 @@ if test "x$enable_va" = xyes; then
HAVE_ST_VA="yes"
fi
-if test "x$enable_xvmc" = xyes ||
- test "x$enable_vdpau" = xyes ||
- test "x$enable_va" = xyes; then
- GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS g3dvl/dri"
-fi
-
dnl
dnl GLU configuration
dnl
@@ -1880,12 +1875,15 @@ gallium_check_st() {
fi
if test "x$HAVE_ST_XVMC" = xyes && test "x$5" != x; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS $5"
+ NEED_G3DVL_DRI="yes"
fi
if test "x$HAVE_ST_VDPAU" = xyes && test "x$6" != x; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS $6"
+ NEED_G3DVL_DRI="yes"
fi
if test "x$HAVE_ST_VA" = xyes && test "x$7" != x; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS $7"
+ NEED_G3DVL_DRI="yes"
fi
}
@@ -1952,6 +1950,13 @@ if test "x$with_gallium_drivers" != x; then
if test "x$HAVE_ST_VA" = xyes; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS va-softpipe"
fi
+ if test "x$HAVE_ST_VDPAU" == xyes ||
+ test "x$HAVE_ST_XVMC" == xyes ||
+ test "x$HAVE_ST_VA" == xyes; then
+ if test "x$HAVE_WINSYS_XLIB" != xyes; then
+ GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/xlib"
+ fi
+ fi
;;
*)
AC_MSG_ERROR([Unknown Gallium driver: $driver])
@@ -1960,6 +1965,10 @@ if test "x$with_gallium_drivers" != x; then
done
fi
+if test "x$NEED_G3DVL_DRI" = xyes; then
+ GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS g3dvl/dri"
+fi
+
dnl prepend CORE_DIRS to SRC_DIRS
SRC_DIRS="$CORE_DIRS $SRC_DIRS"