summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Stellard <thomas.stellard@amd.com>2012-04-17 09:24:29 -0400
committerTom Stellard <thomas.stellard@amd.com>2012-04-23 08:53:47 -0400
commitadb8eca1d85624d9cf2519ad47f2c886556855fb (patch)
tree9ce98fe391f1587fac771bea50b5ed5780b4e646 /configure.ac
parent62b0323cf6af90aa2be89ec76ec3693213b0de5e (diff)
configure.ac: Move HAVE_LLVM definition into configure.ac
Otherwise HAVE_LLVM won't be included in the $(DEFINES) variable for Automake generated Makefiles. Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1b571b95c90..54009581878 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1805,7 +1805,7 @@ if test "x$enable_gallium_llvm" = xyes; then
LLVM_BINDIR=`$LLVM_CONFIG --bindir`
LLVM_CXXFLAGS=`$LLVM_CONFIG --cxxflags`
LLVM_INCLUDEDIR=`$LLVM_CONFIG --includedir`
- DEFINES="$DEFINES -D__STDC_CONSTANT_MACROS"
+ DEFINES="${DEFINES} -DHAVE_LLVM=`echo $LLVM_VERSION | sed -e 's/\([[0-9]]\)\.\([[0-9]]\)/0x0\10\2/g'`"
MESA_LLVM=1
else
MESA_LLVM=0