summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2011-09-20 14:01:45 +0800
committerChia-I Wu <olv@lunarg.com>2011-09-20 17:44:20 +0800
commita5f8d37be141fac5c4ac605163a552ac64324e15 (patch)
tree7573dd4f41357c72b5a57ce74b894e0fbad33840 /configure.ac
parent5eca41665bbd6deb5ffff011e47ff0cec41916da (diff)
st/egl: add support for null platform
The backend calls null_sw_create() to create sw_winsys. And that is pretty much it...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a686a11aa19..b2606bf647a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1636,6 +1636,9 @@ yes)
if test "$plat" = "fbdev"; then
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/fbdev"
fi
+ if test "$plat" = "null"; then
+ GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/null"
+ fi
if test "$plat" = "wayland"; then
PKG_CHECK_MODULES([WAYLAND], [wayland-client wayland-server],, \
[AC_MSG_ERROR([cannot find libwayland-client])])