summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Stellard <thomas.stellard@amd.com>2012-05-02 11:06:13 -0400
committerTom Stellard <thomas.stellard@amd.com>2012-06-01 11:28:09 -0400
commit7a6b5d42d8f47bee84a6ef387a0939cac4569fb4 (patch)
tree80dd90b9e12ab45824cf4b79486070a51864ab5e /configure.ac
parentd416780f396c28be977430e0d2225fa4a95780bc (diff)
clover: Link to the necessary LLVM and Clang libs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 07b64830d76..db68a87f007 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1854,6 +1854,9 @@ if test "x$enable_gallium_llvm" = xyes; then
LLVM_LIBS="-lLLVM-`$LLVM_CONFIG --version`"
else
LLVM_LIBS="`$LLVM_CONFIG --libs engine bitwriter`"
+ if test "x$enable_opencl" = xyes; then
+ LLVM_LIBS="${LLVM_LIBS} `llvm-config --libs ipo linker instrumentation`"
+ fi
fi
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
LLVM_BINDIR=`$LLVM_CONFIG --bindir`