summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancisco Jerez <currojerez@riseup.net>2012-04-25 22:16:26 +0200
committerFrancisco Jerez <currojerez@riseup.net>2012-05-11 12:39:44 +0200
commit66f7fd99fa1d8c8e3b09fadd5624db9968b67506 (patch)
tree823985fa137d154aa4557767f97f47d54191a954 /configure.ac
parent317be33d73228fe8b340de8e029ff24b6e0d95b5 (diff)
gallium/tests/trivial: Switch to the pipe loader.
It simplifies things slightly, and besides, it makes possible to execute the trivial tests on a hardware device instead of being limited to software rendering. Reviewed-by: Jakob Bornecrantz <jakob@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4b26e72d351..3c742cdd542 100644
--- a/configure.ac
+++ b/configure.ac
@@ -643,6 +643,12 @@ AC_ARG_ENABLE([r600-llvm-compiler],
[enable_r600_llvm="$enableval"],
[enable_r600_llvm=no])
+AC_ARG_ENABLE([gallium_tests],
+ [AS_HELP_STRING([--enable-gallium-tests],
+ [Enable optional Gallium tests) @<:@default=disable@:>@])],
+ [enable_gallium_tests="$enableval"],
+ [enable_gallium_tests=no])
+
# Option for Gallium drivers
GALLIUM_DRIVERS_DEFAULT="r300,r600,svga,swrast"
@@ -1967,6 +1973,11 @@ if test "x$with_gallium_drivers" != x; then
done
fi
+if test "x$enable_gallium_tests" = xyes; then
+ SRC_DIRS="$SRC_DIRS gallium/tests/trivial"
+ enable_gallium_loader=yes
+fi
+
if test "x$enable_gallium_loader" = xyes; then
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/null"
GALLIUM_PIPE_LOADER_DEFINES="-DHAVE_PIPE_LOADER_SW"