summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Hourihane <alanh@vmware.com>2011-06-28 17:40:24 +0100
committerAlan Hourihane <alanh@vmware.com>2011-06-28 17:41:39 +0100
commit6479922499638b81569db20394c6cb59e6baf989 (patch)
treed11e1805c7f3b72f31988c95887165581a5e6008 /configure.ac
parentdb78643182dc39ed592dd8c2e5fc7c8eeb7316a1 (diff)
glx: Check HAVE_XF86VIDMODE before adding it as an implicit link
library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7fbba7d62d6..acf9f0604c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -883,7 +883,11 @@ dri|no) # these checks are still desired when there is no mesa_driver
else
# should check these...
X11_INCLUDES="$X11_INCLUDES $X_CFLAGS"
- GL_LIB_DEPS="$X_LIBS -lX11 -lXext -lXxf86vm -lXdamage -lXfixes"
+ if test "x$HAVE_XF86VIDMODE" == xyes; then
+ GL_LIB_DEPS="$X_LIBS -lX11 -lXext -lXxf86vm -lXdamage -lXfixes"
+ else
+ GL_LIB_DEPS="$X_LIBS -lX11 -lXext -lXdamage -lXfixes"
+ fi
GL_PC_LIB_PRIV="$GL_LIB_DEPS"
GL_PC_CFLAGS="$X11_INCLUDES"