summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-02-25 17:45:34 -0800
committerDan Nicholson <dbn.lists@gmail.com>2009-02-25 17:45:34 -0800
commit53b373451142aeea9111143d7902bf8f5716ef75 (patch)
tree2cedd0a3cff371a5328507e28a45e361e3ade6f5 /configure.ac
parentd0415a5a01c1a8c2c2a389d977401a7f6cee031b (diff)
autoconf: Fixup EGL build
This gets the needed libraries pulled in for libEGL for autoconf.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bc233a75099..a57e5b3ea7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -856,6 +856,19 @@ AC_SUBST([OSMESA_PC_REQ])
AC_SUBST([OSMESA_PC_LIB_PRIV])
dnl
+dnl EGL configuration
+dnl
+if test "$x11_pkgconfig" = yes; then
+ PKG_CHECK_MODULES([EGL],[x11])
+ EGL_LIB_DEPS="$EGL_LIBS"
+else
+ # should check these...
+ EGL_LIB_DEPS="$X_LIBS -lX11"
+fi
+EGL_LIB_DEPS="$EGL_LIB_DEPS $DLOPEN_LIBS $OS_LIBS"
+AC_SUBST([EGL_LIB_DEPS])
+
+dnl
dnl GLU configuration
dnl
AC_ARG_ENABLE([glu],