summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-05-26 15:11:50 +0200
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2011-06-23 21:07:17 +0200
commit48d4a001b3faaa707716ea6bd93dd98b487768ce (patch)
tree105d49ff1db5cecbc01f3feb5ce5fbb824c63cdb /configure.ac
parent2ff797060d4ffbe1c1bf5b605ea5d4f9e588da41 (diff)
gbm: Add gallium (drm) backend
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 249a68937cc..dbf8fe5caca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -559,6 +559,13 @@ AC_ARG_ENABLE([gallium_egl],
@<:@default=disable@:>@])],
[enable_gallium_egl="$enableval"],
[enable_gallium_egl=no])
+AC_ARG_ENABLE([gallium_gbm],
+ [AS_HELP_STRING([--enable-gallium-gbm],
+ [enable optional gbm state tracker (not required for
+ gbm support in Gallium)
+ @<:@default=disable@:>@])],
+ [enable_gallium_gbm="$enableval"],
+ [enable_gallium_gbm=no])
# Option for Gallium drivers
GALLIUM_DRIVERS_DEFAULT="r300,r600,swrast"
@@ -1305,6 +1312,22 @@ if test "x$enable_gallium_egl" = xyes; then
fi
dnl
+dnl gbm Gallium configuration
+dnl
+if test "x$enable_gallium_gbm" = xyes; then
+ if test "x$with_gallium_drivers" = x; then
+ AC_MSG_ERROR([cannot enable gbm_gallium without Gallium])
+ fi
+ if test "x$enable_gbm" = xno; then
+ AC_MSG_ERROR([cannot enable gbm_gallium without gbm])
+ fi
+
+ GALLIUM_STATE_TRACKERS_DIRS="gbm $GALLIUM_STATE_TRACKERS_DIRS"
+ GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS gbm"
+ HAVE_ST_GBM="yes"
+fi
+
+dnl
dnl X.Org DDX configuration
dnl
if test "x$enable_xorg" = xyes; then