summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2013-01-31 11:47:55 +0100
committerMichel Dänzer <michel@daenzer.net>2013-02-01 11:42:09 +0100
commit3b888f534cd42065b01ede8b9c646a2be0015509 (patch)
tree85282a3f6778a75b9832da934b61bb743e78502a /configure.ac
parent9824755daef3beed6b6d5b5d248db9ecf04e2900 (diff)
configure.ac: GLX cannot work without OpenGL
GLX uses mapi/glapi/libglapi.la, which is only built for OpenGL. If the user specified --enable-xlib-glx --disable-opengl, error out, as these cannot be both observed at the same time. If the user just specified --disable-opengl but not --disable-glx, print a warning and disable GLX as well. NOTE: This is a candidate for the stable branches. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=59364 Tested-by: Tom Stellard <thomas.stellard@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cfd52bfcf06..95c9f3dbe9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -701,6 +701,16 @@ if test "x$enable_dri$enable_xlib_glx" = xyesyes; then
AC_MSG_ERROR([DRI and Xlib-GLX cannot be built together])
fi
+if test "x$enable_opengl$enable_xlib_glx" = xnoyes; then
+ AC_MSG_ERROR([Xlib-GLX cannot be built without OpenGL])
+fi
+
+# Disable GLX if OpenGL is not enabled
+if test "x$enable_glx$enable_opengl" = xyesno; then
+ AC_MSG_WARN([OpenGL not enabled, disabling GLX])
+ enable_glx=no
+fi
+
# Disable GLX if DRI and Xlib-GLX are not enabled
if test "x$enable_glx" = xyes -a \
"x$enable_dri" = xno -a \