summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Hellstrom <thellstrom@vmware.com>2011-11-24 21:54:54 +0100
committerThomas Hellstrom <thellstrom@vmware.com>2011-11-25 16:38:36 +0100
commit32b1641a59610d94c0b56bf0494b2fc1cf400e3e (patch)
treed03c7c7eac1cd4eb0d0b917b3225d3a63acf5896 /configure.ac
parent4d04367eca66a85e26f7c0f5d6392823d13880f6 (diff)
st/xa, xa/vmwgfx: Generate exported symbol list from the st/xa symbols.
Signed-off-by: Thomas Hellstrom <thellstrom@vmware.com> Reviewed-by: Jakob Bornecrantz <jakob@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8885a6d74e5..febb9f68098 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1469,8 +1469,20 @@ dnl
dnl XA configuration
dnl
if test "x$enable_xa" = xyes; then
+AC_PROG_AWK
+AC_PROG_GREP
+AC_CHECK_PROG(NM, nm, "nm")
+if test "x$AWK" = x || test "x$GREP" = x || test "x$NM" = x; then
+AC_MSG_WARN([Missing one of nm, grep or awk. Disabling xa.])
+enable_xa=no
+fi
+fi
+if test "x$enable_xa" = xyes; then
GALLIUM_STATE_TRACKERS_DIRS="xa $GALLIUM_STATE_TRACKERS_DIRS"
HAVE_ST_XA=yes
+ AC_SUBST(AWK)
+ AC_SUBST(GREP)
+ AC_SUBST(NM)
fi
dnl