summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@intel.com>2018-09-12 13:24:12 -0700
committerLucas De Marchi <lucas.demarchi@intel.com>2018-09-19 22:46:45 -0700
commitba808253bc16b481dbee69323d5a560b103d1091 (patch)
tree38f80c3fd6bf4e4333b87a93a83d2c08e500d4c1 /tests/meson.build
parent67967e9b5c0bb15eb7c95f060810d454c8eb6732 (diff)
meson: make symbols hidden by default
Now that symbols that should be exported are annotated accordingly, make all the rest hidden by default. Signed-off-by: Lucas De Marchi <lucas.demarchi@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/meson.build b/tests/meson.build
index fdf950b7..6c8ddd9c 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -53,7 +53,7 @@ drmsl = executable(
files('drmsl.c'),
include_directories : [inc_root, inc_drm],
link_with : libdrm,
- c_args : warn_c_args,
+ c_args : libdrm_c_args,
)
hash = executable(
@@ -61,7 +61,7 @@ hash = executable(
files('hash.c'),
include_directories : [inc_root, inc_drm],
link_with : libdrm,
- c_args : warn_c_args,
+ c_args : libdrm_c_args,
)
random = executable(
@@ -69,7 +69,7 @@ random = executable(
files('random.c'),
include_directories : [inc_root, inc_drm],
link_with : libdrm,
- c_args : warn_c_args,
+ c_args : libdrm_c_args,
)
drmdevice = executable(
@@ -77,7 +77,7 @@ drmdevice = executable(
files('drmdevice.c'),
include_directories : [inc_root, inc_drm],
link_with : libdrm,
- c_args : warn_c_args,
+ c_args : libdrm_c_args,
)
test('random', random, timeout : 240)