summaryrefslogtreecommitdiff
path: root/src/rbug/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/rbug/meson.build')
-rw-r--r--src/rbug/meson.build43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/rbug/meson.build b/src/rbug/meson.build
new file mode 100644
index 00000000..a1714ac4
--- /dev/null
+++ b/src/rbug/meson.build
@@ -0,0 +1,43 @@
+# Copyright © 2017 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+executables = [
+ 'bin_to_bmp',
+ 'simple_client',
+ 'simple_server',
+ 'shdr_info',
+ 'shdr_dump',
+ 'shdr_disable',
+ 'ctx_info',
+ 'ctx_rule',
+ 'tex_info',
+ 'tex_dump',
+]
+foreach e : executables
+ executable(
+ e, e + '.c',
+ include_directories : include_directories(
+ join_paths(mesa_source, 'src/gallium/include'),
+ join_paths(mesa_source, 'src/gallium/auxiliary'),
+ join_paths(mesa_source, 'src'),
+ join_paths(mesa_source, 'include'),
+ ),
+ )
+endforeach