summaryrefslogtreecommitdiff
path: root/sfx2/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sfx2/meson.build')
-rw-r--r--sfx2/meson.build26
1 files changed, 13 insertions, 13 deletions
diff --git a/sfx2/meson.build b/sfx2/meson.build
index 1842d4bdc95f..9b62543f7721 100644
--- a/sfx2/meson.build
+++ b/sfx2/meson.build
@@ -32,6 +32,7 @@ sfx_lib = shared_library('sfxlo',
'source/appl/fileobj.cxx',
'source/appl/flatpak.cxx',
'source/appl/fwkhelper.cxx',
+ 'source/appl/getbasctlfunction.cxx',
'source/appl/helpdispatch.cxx',
'source/appl/helpinterceptor.cxx',
'source/appl/impldde.cxx',
@@ -67,6 +68,7 @@ sfx_lib = shared_library('sfxlo',
'source/control/ctrlfactoryimpl.cxx',
'source/control/dispatch.cxx',
'source/control/itemdel.cxx',
+ 'source/control/listview.cxx',
'source/control/minfitem.cxx',
'source/control/msg.cxx',
'source/control/msgpool.cxx',
@@ -79,6 +81,7 @@ sfx_lib = shared_library('sfxlo',
'source/control/sorgitm.cxx',
'source/control/statcach.cxx',
'source/control/templatedefaultview.cxx',
+ 'source/control/templatedlglocalview.cxx',
'source/control/templateviewitem.cxx',
'source/control/templatelocalview.cxx',
'source/control/templatecontaineritem.cxx',
@@ -128,6 +131,10 @@ sfx_lib = shared_library('sfxlo',
'source/dialog/tplcitem.cxx',
'source/dialog/tplpitem.cxx',
'source/dialog/versdlg.cxx',
+ 'source/devtools/DevelopmentToolChildWindow.cxx',
+ 'source/devtools/DevelopmentToolDockingWindow.cxx',
+ 'source/devtools/DocumentModelTreeHandler.cxx',
+ 'source/devtools/ObjectInspectorTreeHandler.cxx',
'source/doc/DocumentMetadataAccess.cxx',
'source/doc/DocumentSigner.cxx',
'source/doc/Metadatable.cxx',
@@ -164,6 +171,7 @@ sfx_lib = shared_library('sfxlo',
'source/doc/sfxbasemodel.cxx',
'source/doc/sfxmodelfactory.cxx',
'source/doc/SfxRedactionHelper.cxx',
+ 'source/doc/signaturestate.cxx',
'source/doc/syspath.cxx',
'source/doc/zoomitem.cxx',
'source/doc/templatedlg.cxx',
@@ -171,12 +179,7 @@ sfx_lib = shared_library('sfxlo',
'source/doc/saveastemplatedlg.cxx',
'source/explorer/nochaos.cxx',
'source/inet/inettbc.cxx',
- 'source/notebookbar/ContextVBox.cxx',
- 'source/notebookbar/DropdownBox.cxx',
- 'source/notebookbar/PriorityHBox.cxx',
- 'source/notebookbar/PriorityMergedHBox.cxx',
'source/notebookbar/SfxNotebookBar.cxx',
- 'source/notebookbar/NotebookbarPopup.cxx',
'source/notebookbar/NotebookbarTabControl.cxx',
'source/notify/eventsupplier.cxx',
'source/notify/globalevents.cxx',
@@ -190,13 +193,10 @@ sfx_lib = shared_library('sfxlo',
'source/sidebar/SidebarModelUpdate.cxx',
'source/sidebar/SidebarPanelBase.cxx',
'source/sidebar/SidebarToolBox.cxx',
- 'source/sidebar/Accessible.cxx',
- 'source/sidebar/AccessibleTitleBar.cxx',
'source/sidebar/AsynchronousCall.cxx',
'source/sidebar/Context.cxx',
'source/sidebar/ContextChangeBroadcaster.cxx',
'source/sidebar/ContextList.cxx',
- 'source/sidebar/ControlFactory.cxx',
'source/sidebar/ControllerFactory.cxx',
'source/sidebar/ControllerItem.cxx',
'source/sidebar/Deck.cxx',
@@ -205,16 +205,13 @@ sfx_lib = shared_library('sfxlo',
'source/sidebar/DeckTitleBar.cxx',
'source/sidebar/DrawHelper.cxx',
'source/sidebar/FocusManager.cxx',
- 'source/sidebar/MenuButton.cxx',
'source/sidebar/IContextChangeReceiver.cxx',
'source/sidebar/ILayoutableWindow.cxx',
- 'source/sidebar/Paint.cxx',
'source/sidebar/Panel.cxx',
'source/sidebar/PanelDescriptor.cxx',
'source/sidebar/PanelTitleBar.cxx',
'source/sidebar/ResourceManager.cxx',
'source/sidebar/TabBar.cxx',
- 'source/sidebar/TabItem.cxx',
'source/sidebar/TitleBar.cxx',
'source/sidebar/Theme.cxx',
'source/sidebar/Tools.cxx',
@@ -243,7 +240,8 @@ sfx_lib = shared_library('sfxlo',
'source/view/viewfrm2.cxx',
'source/view/viewprn.cxx',
'source/view/viewsh.cxx',
- udk_fake_h, off_fake_h, common_hxx, sfxslots_hxx, inet_hxx, protocolhandler_hxx, sidebar_hxx, toolbarmode_hxx,
+ 'source/sidebar/PanelLayout.cxx',
+ udk_fake_h, off_fake_h, common_hxx, sfxslots_hxx, inet_hxx, protocolhandler_hxx, sidebar_hxx, toolbarmode_hxx, infobar_hxx,
cpp_args: ['-DSFX2_DLLIMPLEMENTATION',
'-DLIBO_INTERNAL_ONLY'],
include_directories: [main_inc, udkh_inc, offapi_inc, 'inc', 'source/inc', setup_inc],
@@ -253,7 +251,7 @@ sfx_lib = shared_library('sfxlo',
cppu_lib,
cppuhelper_lib,
drawinglayer_lib,
- fwe_lib,
+ fwk_lib,
i18nlangtag_lib,
i18nutil_lib,
sal_lib,
@@ -270,6 +268,8 @@ sfx_lib = shared_library('sfxlo',
vcl_lib,
],
dependencies: [
+ icuuc_dep,
+ icu18_dep,
libxml_dep,
orcus_dep,
],