summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5bca1f5dccdf..7d0ae76133f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1249,7 +1249,7 @@ AC_ARG_WITH(galleries,
AC_ARG_WITH(theme,
AS_HELP_STRING([--with-theme="theme1 theme2..."],
[Choose which themes to include. By default those themes with an '*' are included.
- Possible choices: *crystal, *default (galaxy), *hicontrast, human, industrial, *oxygen, *tango, *tango_testing.]),
+ Possible choices: *crystal, *default (galaxy), *hicontrast, human, industrial, *oxygen, *sifr, *tango, *tango_testing.]),
,)
AC_ARG_WITH(helppack-integration,
@@ -10695,7 +10695,7 @@ dnl ===================================================================
AC_MSG_CHECKING([which themes to include])
# if none given use default subset of available themes
if test "x$with_theme" = "x" -o "x$with_theme" = "xyes"; then
- with_theme="crystal default hicontrast oxygen tango"
+ with_theme="crystal default hicontrast oxygen tango sifr"
test "$ENABLE_RELEASE_BUILD" = "FALSE" && with_theme="$with_theme tango_testing"
fi
@@ -10703,7 +10703,7 @@ WITH_THEMES=""
if test "x$with_theme" != "xno"; then
for theme in $with_theme; do
case $theme in
- crystal|default|galaxy|hicontrast|human|industrial|oxygen|tango|tango_testing) : ;;
+ crystal|default|galaxy|hicontrast|human|industrial|oxygen|sifr|tango|tango_testing) : ;;
*) AC_MSG_ERROR([Unknown value for --with-theme: $theme]) ;;
esac
WITH_THEMES="$WITH_THEMES $theme"
@@ -11869,7 +11869,7 @@ if test "$enable_mpl_subset" = "yes"; then
fi
for theme in $WITH_THEMES; do
case $theme in
- crystal|default|hicontrast|human|oxygen)
+ crystal|default|hicontrast|human|oxygen|sifr)
AC_MSG_ERROR([need to disable icon themes from '$WITH_THEMES': $theme present, use --with-theme=tango]) ;;
*) : ;;
esac