summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2011-11-07 16:59:01 +0100
committerMichael Stahl <mstahl@redhat.com>2011-11-07 16:59:01 +0100
commitf89d0f3ab017cee2fa078a1a8e1aebee7d708fd2 (patch)
tree5e66b8309a994b192ca008ddfb285383383af1af /configure.in
parentf8d64ffd4a2ee3f6b3340a2bbac21eb7d2b4551c (diff)
configure: remove --with-system-libxslt:
This option must have the same value as --with-system-libxml, so it is redundant.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 4 insertions, 30 deletions
diff --git a/configure.in b/configure.in
index 0f81959800c7..9eb5d815905f 100644
--- a/configure.in
+++ b/configure.in
@@ -1030,7 +1030,7 @@ AC_ARG_WITH(system-libwpg,
AC_ARG_WITH(system-libxml,
AS_HELP_STRING([--with-system-libxml],
- [Use libxml already on system.]),,
+ [Use libxml/libxslt already on system.]),,
[if test "$_os" = "Darwin" -o $_os = "iOS"; then
with_system_libxml=yes
else
@@ -1220,17 +1220,6 @@ AC_ARG_WITH(saxon-jar,
[Specify path to jarfile manually.]),
SAXON_JAR=$withval)
-AC_ARG_WITH(system-libxslt,
- AS_HELP_STRING([--with-system-libxslt],
- [Use libxslt already on system.]),
- [if test "$_os" = "Darwin"; then
- with_system_libxslt=yes
- else
- if test -n "$with_system_libs"; then
- with_system_libxslt="$with_system_libs";
- fi
- fi])
-
AC_ARG_WITH(system-odbc,
AS_HELP_STRING([--with-system-odbc],
[Use the odbc headers already on system.]),,
@@ -4829,28 +4818,13 @@ if test "$test_freetype" = "yes"; then
fi
AC_SUBST(USE_FT_EMBOLDEN)
-if test "$with_system_libxslt" = "yes"; then
- if test "$with_system_libxml" != "yes"; then
- # somehow AC_MSG_WARN won't work...
- echo "to prevent incompatibilities between internal libxml2 and libxslt, the office will be build with system-libxml"
- echo "to prevent incompatibilities between internal libxml2 and libxslt, the office will be build with system-libxml" >> warn
- with_system_libxml=yes
- fi
-fi
-if test "$with_system_libxml" = "yes"; then
- if test "$with_system_libxslt" != "yes"; then
- # somehow AC_MSG_WARN won't work...
- echo "to prevent incompatibilities between internal libxslt and libxml2, the office will be build with system-libxslt"
- echo "to prevent incompatibilities between internal libxslt and libxml2, the office will be build with system-libxslt" >> warn
- with_system_libxslt=yes
- fi
-fi
-
# ===================================================================
# Check for system libxslt
+# to prevent incompatibilities between internal libxml2 and external libxslt,
+# or vice versa, use with_system_libxml here
# ===================================================================
AC_MSG_CHECKING([which libxslt to use])
-if test "$with_system_libxslt" = "yes"; then
+if test "$with_system_libxml" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_LIBXSLT=YES
if test "$_os" = "Darwin"; then