summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2011-11-14 13:56:54 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2011-11-14 13:57:26 -0600
commitf72516ed25d25963f497396985d56344eb3ff465 (patch)
treee9d316413ce6eb7096adb09c66870e57245ffcc7 /configure.in
parent718f032a3c9dc5071f86a6d69321dc23d6b56188 (diff)
avoid trying to run stuff at configure time due to cross-compile need
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 8 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 9a5fb6811fdb..492670613c64 100644
--- a/configure.in
+++ b/configure.in
@@ -8558,6 +8558,7 @@ dnl ===================================================================
dnl Test whether to build cairo or rely on the system version
dnl ===================================================================
+
SYSTEM_CAIRO=""
AC_MSG_CHECKING([whether to use the system cairo])
@@ -8569,19 +8570,17 @@ if test "$with_system_cairo" = "yes"; then
PKG_CHECK_MODULES( CAIRO, cairo >= 1.0.2 )
if test "$with_system_xextensions_headers" != "no"; then
- AC_MSG_CHECKING([whether Xrender.h defines PictStandardA8])
- AC_RUN_IFELSE([AC_LANG_SOURCE([[
-#include <X11/extensions/Xrender.h>
+ AC_MSG_CHECKING([whether Xrender.h defines PictStandardA8])
+ AC_LANG_PUSH([C])
-int main(int argc, char **argv) {
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <X11/extensions/Xrender.h>]],[[
#ifdef PictStandardA8
- return 0;
#else
- return 1;
+ return fail;
#endif
-}
- ]])],[AC_MSG_RESULT([yes])],[AC_MSG_ERROR([no, X headers too old.])
- ],[])
+]])],[AC_MSG_RESULT([yes])],[AC_MSG_ERROR([no, X headers too old.])])
+
+ AC_LANG_POP([C])
fi
MINGW_EXTERNAL_DLLS="$MINGW_EXTERNAL_DLLS libfontconfig-1.dll libfreetype-6.dll libpixman-1-0.dll libpng15-15.dll libcairo-2.dll"
else