summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2011-11-01 10:59:38 +0100
committerTomas Chvatal <tchvatal@suse.cz>2011-11-01 11:03:51 +0100
commitf1f6f30bac305115fdf58fc4f2ecabaf236a519c (patch)
tree6edb33f8ffc292d27b9cab87585b5bfe3bfbf95a /configure.in
parent8be381cf6662e97579c804ec022da085d370829c (diff)
When building with gconf check for orbit too.
This avoids build error like: Entering /var/tmp/portage/app-office/libreoffice-3.4.3.2-r1/work/libreoffice-bootstrap-3.4.3.2/shell/source/backends/gconfbe Package ORBit-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `ORBit-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'ORBit-2.0' found dmake: Error code 1, while making 'Shell escape' Also update gvfs check to require gconf switch enabled instead of running pkgconfig again.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 65b81c124b56..b1c9e1870cc9 100644
--- a/configure.in
+++ b/configure.in
@@ -6956,7 +6956,7 @@ AC_MSG_CHECKING([whether to enable GConf support])
if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_gconf" = "yes"; then
ENABLE_GCONF="TRUE"
AC_MSG_RESULT([yes])
- PKG_CHECK_MODULES( GCONF, gconf-2.0 )
+ PKG_CHECK_MODULES( GCONF, gconf-2.0 orbit-2.0 )
else
AC_MSG_RESULT([no])
fi
@@ -6968,13 +6968,10 @@ dnl ===================================================================
ENABLE_GNOMEVFS=""
AC_MSG_CHECKING([whether to enable GNOME VFS support])
-if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_gnome_vfs" = "yes"; then
+if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_gnome_vfs" = "yes" -a "$enable_gconf" = "yes"; then
ENABLE_GNOMEVFS="TRUE"
AC_MSG_RESULT([yes])
PKG_CHECK_MODULES( GNOMEVFS, gnome-vfs-2.0 >= 2.6.0 )
- if test "$ENABLE_GCONF" != "TRUE"; then
- PKG_CHECK_MODULES( GCONF, gconf-2.0 )
- fi
else
AC_MSG_RESULT([no])
fi