summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@suse.com>2011-11-03 19:48:25 +0000
committerMichael Meeks <michael.meeks@suse.com>2011-11-03 19:48:25 +0000
commite53ac9984cd745736ec07d039ca92451732392a1 (patch)
tree7f07e8d9f76903ffccf371deeb9f2cc15bab8409 /configure.in
parent3c8b99a3fcbaf0192c9b5ffe2b94f7f84e2dde2b (diff)
gtk3: Check for gtk3 >= 3.2 - we need that for broadway anyway
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d95dc7c4addf..392cd15241d3 100644
--- a/configure.in
+++ b/configure.in
@@ -6858,9 +6858,11 @@ if test "x$enable_gtk3" = "xyes"; then
if test "$with_system_cairo" != yes; then
echo "System cairo required for gtk3 support, please use --system-cairo"
fi
- PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.0 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
+ PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.2 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
if test "x$ENABLE_GTK3" = "xTRUE"; then
R="gtk3"
+ else
+ AC_MSG_ERROR([gtk3 libraries of the correct versions, not found])
fi
fi
AC_SUBST(GTK3_LIBS)