summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2012-09-19 22:13:36 +0200
committerMichael Meeks <michael.meeks@suse.com>2012-09-20 09:48:29 +0000
commite0f90c3060f542885d834314a9097353d0cb2ba2 (patch)
tree375ff16a94c6bb03dcef4d085027f53458d67c01 /configure.in
parentb7c41f1d1fcabc8f4abc670d5a18546a117b540a (diff)
introduce new option --disable-cve-tests
Change-Id: I288638c4a70396ccb7354b20e901aa0c46ffe442 Reviewed-on: https://gerrit.libreoffice.org/653 Reviewed-by: Michael Meeks <michael.meeks@suse.com> Tested-by: Michael Meeks <michael.meeks@suse.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 10106724ee35..e29a0e84cf52 100644
--- a/configure.in
+++ b/configure.in
@@ -988,6 +988,11 @@ AC_ARG_ENABLE(neon,
[Disable neon and the compilation of webdav binding.]),
,)
+AC_ARG_ENABLE(cve-tests,
+ AS_HELP_STRING([--disable-cve-tests],
+ [Prevent CVE tests to be executed]),
+,)
+
AC_ARG_ENABLE(build-unowinreg,
AS_HELP_STRING([--enable-build-unowinreg],
[Do not use the prebuilt unowinreg.dll. Build it instead. The MinGW C++
@@ -8623,6 +8628,18 @@ AC_SUBST([MINGW_TASN1_DLL])
fi
dnl ===================================================================
+dnl Check for disabling cve_tests
+dnl ===================================================================
+AC_MSG_CHECKING([whether to execute CVE tests])
+if test "$enable_cve_tests" = "no"; then
+ AC_MSG_RESULT([no])
+ DISABLE_CVE_TESTS=TRUE
+ AC_SUBST(DISABLE_CVE_TESTS)
+else
+ AC_MSG_RESULT([yes])
+fi
+
+dnl ===================================================================
dnl Check for system openssl
dnl ===================================================================
if test "$_os" = "Darwin" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o \