summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2012-09-06 18:43:15 +0200
committerMichael Stahl <mstahl@redhat.com>2012-09-06 18:46:41 +0200
commitd9cbc837f84c415f5949a6893764dae8268f0d85 (patch)
treec3afc172a3b2a7059578441bcff0365beeaf1fc5 /configure.in
parent47919e05f68a6871031b92ad028e4345a51bf5c9 (diff)
gbuild: disable symbols on --enable-dbgutil --disable-symbols
Due to the setup of gb_DEBUGLEVEL in gbuild.mk, gb_SYMBOL was always enabled when --enable-dbgutil is set, with no way to override it. Fix that by turning configure's ENABLE_SYMBOLS into a tri-state, where the new "FALSE" value, set by an explicit --disable-symbols, overrides any implicit way of enabling symbols. But by default an --enable-dbgutil still enables gb_SYMBOL. Change-Id: I94c609863980ed1ab9c73d7a4861c394442b531d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 754c79d39eec..5291f0f529fb 100644
--- a/configure.in
+++ b/configure.in
@@ -4048,7 +4048,11 @@ if test -n "$enable_symbols" -a "$enable_symbols" != "no"; then
ENABLE_SYMBOLS="TRUE"
AC_MSG_RESULT([yes])
else
- ENABLE_SYMBOLS=
+ if test -n "$enable_symbols" -a "$enable_symbols" = "no"; then
+ ENABLE_SYMBOLS="FALSE"
+ else
+ ENABLE_SYMBOLS=
+ fi
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_SYMBOLS)