summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2012-09-11 02:30:09 +0200
committerRene Engelhard <rene@debian.org>2012-09-11 13:42:59 +0200
commitbea6149df2a611a6958ab1d9fa989dd30d525cd7 (patch)
treec12d0a039444d627ff32baee7d4d0d042b1d8397 /configure.in
parentb6640bdef03e89b720974d72ca42fb88937a70c8 (diff)
default to off for packagekit usage; add --enable-packagekit
Change-Id: Ib644cc3768ced8a1959fb9ea9f7f24e29fce87ad
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 980486292b99..18286b6b3b7f 100644
--- a/configure.in
+++ b/configure.in
@@ -9262,6 +9262,20 @@ AC_SUBST(ENABLE_DBUS)
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
+AC_MSG_CHECKING([whether to enable font install via packagekit])
+if test "$ENABLE_DBUS" = "TRUE"; then
+ if test -n "$enable_packagekit"; then
+ ENABLE_PACKAGEKIT=YES
+ AC_MSG_RESULT([yes])
+ else
+ ENABLE_PACKAGEKIT=NO
+ AC_MSG_RESULT([no])
+ fi
+else
+ AC_MSG_RESULT([no, dbus disabled.])
+fi
+AC_SUBST(ENABLE_PACKAGEKIT)
+
dnl ===================================================================
dnl Check whether the gtk 2.0 libraries are available.
dnl ===================================================================