summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJürgen Schmidt <jsc@apache.org>2011-11-14 13:03:32 +0000
committerJürgen Schmidt <jsc@apache.org>2011-11-14 13:03:32 +0000
commita06930ead7444b69656482cab6b3a0e9f9cc5239 (patch)
treeca5e925253f21048da74ed01b771274691aceb36 /configure.in
parentba0d0a588d5bfc00e8076ec0e9e0c9d38154a854 (diff)
118592, remove incompatible xpdf, applied patch, thanks to Andre Fischer (af)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 4 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 681b39a1c5cc..b3bac606ae40 100644
--- a/configure.in
+++ b/configure.in
@@ -419,7 +419,7 @@ AC_ARG_ENABLE(presenter-console,
[ --enable-presenter-console enables the build of the Presenter Console extension
],,)
AC_ARG_ENABLE(pdfimport,
-[ --enable-pdfimport enables the build of the PDF Import extension and xpdf
+[ --enable-pdfimport enables the build of the PDF Import extension
],,)
AC_ARG_ENABLE(wiki-publisher,
[ --enable-wiki-publisher enables the build of the Wiki Publisher extension
@@ -5950,22 +5950,16 @@ if test -n "$enable_pdfimport" -a "$enable_pdfimport" != "no"; then
dnl ===================================================================
dnl Check for system poppler
dnl ===================================================================
- AC_MSG_CHECKING([which pdf backend to use])
+ AC_MSG_CHECKING([whether to use system pdf backend])
if test -n "$with_system_poppler" -o -n "$with_system_libs" && \
test "$with_system_poppler" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_POPPLER=YES
PKG_CHECK_MODULES( POPPLER, poppler >= 0.8.0 )
else
- AC_MSG_RESULT([internal])
+ AC_MSG_RESULT([no])
SYSTEM_POPPLER=NO
- BUILD_TYPE="$BUILD_TYPE XPDF"
- AC_MSG_CHECKING([for xpdf module])
- if test -d ./xpdf; then
- AC_MSG_RESULT([OK])
- else
- AC_MSG_ERROR([not existing. get it (did you get the -extensions tarball?)])
- fi
+ ENABLE_PDFIMPORT=NO
fi
else
AC_MSG_RESULT([no])