summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2011-11-08 11:13:52 +0200
committerTor Lillqvist <tlillqvist@suse.com>2011-11-08 11:19:43 +0200
commit9b0d9a2ace6d51363f2360621aae44f1b353e4df (patch)
tree39e2f3cad7cc4c278cc2900d8dfed6d8967f58eb /configure.in
parent20fe7d11e935b48126c31ff7629fded87e61ce85 (diff)
Fix syntax errors
1) It is not safe to use the [ command in configure.in; m4 will eat the [ and ] and they will expand to nothing. (Just look in the configure script produced prior to this commit.) Use the test command instead, as elsewhere in the file. 2) Quote the variable being tested for emptiness with test -z. Otherwise, if it *is* empty, the -z will apply to (and eat) the following word, "then", which is not what is intended, and which also causes a syntax error.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ea8eb4c945a6..a6b135aa820e 100644
--- a/configure.in
+++ b/configure.in
@@ -2009,7 +2009,7 @@ if test "$_os" = "Darwin" ; then
MAC_OS_X_VERSION_MIN_REQUIRED="1050"
AC_MSG_WARN([Building with a minimum version requirement > 10.4 break 10.4 compatibility. do not use for deliverable build])
echo "Building with a minimum version requirement > 10.4 break 10.4 compatibility. do not use for deliverable build" >>warn
- if [ -z $save_CC ] ; then
+ if test -z "$save_CC" ; then
CC="gcc-4.2 -m32"
CXX="g++-4.2 -m32"
fi
@@ -2018,7 +2018,7 @@ if test "$_os" = "Darwin" ; then
MAC_OS_X_VERSION_MIN_REQUIRED="1060"
AC_MSG_WARN([Building with a minimum version requirement > 10.4 break 10.4 compatibility. do not use for deliverable build])
echo "Building with a minimum version requirement > 10.4 break 10.4 compatibility. do not use for deliverable build" >>warn
- if [ -z "$save_CC" ] ; then
+ if test -z "$save_CC" ; then
CC="gcc-4.2 -m32"
CXX="g++-4.2 -m32"
fi
@@ -2027,7 +2027,7 @@ if test "$_os" = "Darwin" ; then
MAC_OS_X_VERSION_MIN_REQUIRED="1070"
AC_MSG_WARN([Building with a minimum version requirement > 10.4 break 10.4 compatibility. do not use for deliverable build])
echo "Building with a minimum version requirement > 10.4 break 10.4 compatibility. do not use for deliverable build" >>warn
- if [ -z "$save_CC" ] ; then
+ if test -z "$save_CC" ; then
CC="gcc-4.2 -m32"
CXX="g++-4.2 -m32"
fi