summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2012-09-18 11:23:52 +0200
committerFridrich Strba <fridrich@documentfoundation.org>2012-09-18 14:17:27 +0000
commit903065dda1e574f4791ff40c31e39f14ba710424 (patch)
tree1a8e0724031a3747465d61ae0b7e7c927b2e1292 /configure.in
parentb8a331fefc6332baa62144095d3f26cdb456d2c7 (diff)
switch build system to mork driver implementation
On all non windows platforms no mozilla is used any more. On windows it used for O and OE address book access. Once alternative implementation for it exists, mozilla can be stripped there too. Change-Id: I54144005e6a284326b45a34eb958d170e872471e Reviewed-on: https://gerrit.libreoffice.org/637 Reviewed-by: Fridrich Strba <fridrich@documentfoundation.org> Tested-by: Fridrich Strba <fridrich@documentfoundation.org>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 25 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 75b9175aa4d4..9aaa2eb7d195 100644
--- a/configure.in
+++ b/configure.in
@@ -695,7 +695,7 @@ AC_ARG_ENABLE(pch,
AC_ARG_ENABLE(mozilla,
AS_HELP_STRING([--enable-mozilla],
- [LibreOffice can include a strangely hacked up Mozilla binary for your
+ [LibreOffice can include a strangely hacked up Mozilla binary on Windows
platform, to build with this version, use this option.])
)
@@ -4502,6 +4502,18 @@ if test $_os = Darwin -a "$enable_mozilla" = no; then
fi
dnl ===================================================================
+dnl --enable-mozilla is supported only on Windows
+dnl ===================================================================
+
+if test "$_os" != "WINNT" ; then
+ if test "$enable_mozilla" = "yes"; then
+ AC_MSG_ERROR([--enable-mozilla is only available on Windows])
+ fi
+
+fi
+
+
+dnl ===================================================================
dnl .NET needs special treatment
dnl (does the above comment really mean .NET, or is it misusing
dnl that to mean Visual Studio .NET 2003 ? And does this also
@@ -7865,12 +7877,19 @@ fi
AC_SUBST(SYSTEM_ODBC_HEADERS)
AC_MSG_CHECKING([whether to build Mozilla addressbook connectivity])
-if test "$enable_mozilla" = "no"; then
- AC_MSG_RESULT([no])
-elif test "$with_system_mozilla" = "yes"; then
- AC_MSG_RESULT([no, not possible with system-mozilla])
+if test "$_os" = "WINNT"; then
+ if test "$enable_mozilla" = "no"; then
+ AC_MSG_RESULT([no])
+ elif test "$with_system_mozilla" = "yes"; then
+ AC_MSG_RESULT([no, not possible with system-mozilla])
+ else
+ AC_MSG_RESULT([yes])
+ fi
else
- AC_MSG_RESULT([yes])
+# on all other platforms Mozilla addressbook connectivity
+# is unconditionally built
+# new and shiny mork driver
+ AC_MSG_RESULT([yes])
fi
dnl ===================================================================