summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2011-10-24 14:42:11 +0300
committerTor Lillqvist <tlillqvist@suse.com>2011-10-24 14:43:38 +0300
commit89ae66dac25b8ee12bde52d05395e3a54842d4f7 (patch)
tree602566e551293d529e89ffd44cc4159509b48136 /configure.in
parent81448039ea3f757fcdfc2212a02b0ecf56b7c821 (diff)
I give up on --enable-dbgutil with MSVC
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c94ad6d90534..9ed2979a1a72 100644
--- a/configure.in
+++ b/configure.in
@@ -2306,6 +2306,16 @@ AC_MSG_CHECKING([whether to build with additional debug utilities])
if test -n "$enable_dbgutil" && test "$enable_dbgutil" != "no"; then
PROEXT=""
PRODUCT=""
+
+ # Compiling with MSVC using --enable-dbgutil (i.e. using the
+ # debugging runtime, and defining _DEBUG when compiling) just
+ # causes too many compilation errors. After having spent some
+ # months slowly fixing them one by one, having reached sw, I give
+ # up. Feel free to try again.
+ if test $_os = WINNT; then
+ AC_MSG_ERROR([Sorry, --enable-dgutil won't work with MSVC])
+ fi
+
AC_MSG_RESULT([yes])
# cppunit and graphite expose STL in public headers
if test "$with_system_cppunit" = "yes"; then