summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2011-10-25 10:07:00 +0200
committerDavid Tardon <dtardon@redhat.com>2011-10-25 10:07:32 +0200
commit83a61ecc45682adaedc061374ddc2874d79af82f (patch)
tree3a2b89f4c64d312614a3324203fb4f3d70f85486 /configure.in
parentc6dee8c995caeb78054c1677d6c36fd466b78955 (diff)
do not hardcode mingw sysroot path
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 9ed2979a1a72..54687872cf0d 100644
--- a/configure.in
+++ b/configure.in
@@ -9543,12 +9543,13 @@ AC_SUBST(BUILD_TYPE)
if test "$WITH_MINGW" != "yes" ; then
MINGW_EXTERNAL_DLLS=
else
+ mingw_dlldir=`$CC -print-sysroot`/mingw/bin
for DLL in $MINGW_EXTERNAL_DLLS ; do
AC_MSG_CHECKING([for $DLL])
- if ! test -f "/usr/i686-w64-mingw32/sys-root/mingw/bin/$DLL" ; then
+ if ! test -f "$mingw_dlldir/$DLL" ; then
AC_MSG_ERROR([Could not find $DLL, install the appropriate mingw32-<package>, not only mingw32-<package>-devel.])
fi
- AC_MSG_RESULT([/usr/i686-w64-mingw32/sys-root/mingw/bin/$DLL])
+ AC_MSG_RESULT([$mingw_dlldir/$DLL])
done
fi
AC_SUBST(MINGW_EXTERNAL_DLLS)