summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2012-09-27 20:49:25 +0200
committerRene Engelhard <rene@debian.org>2012-09-27 22:45:03 +0200
commit7b9fb8f6736248f1c218ef1667eae6523487368d (patch)
tree71b22eea5a109002f7e5421b614abf399e656b0f /configure.in
parentc0fb5ed758c9ed8c1bb6b8344592c4781f475443 (diff)
add --with-idlc-cpp to allow use of "normal" cpp
Change-Id: Ib32bb0b3e9cf4ce6aeb60a417a2f07d72facf41d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 23 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 09fb9cb6a186..17b13c61bf05 100644
--- a/configure.in
+++ b/configure.in
@@ -2078,6 +2078,16 @@ AC_ARG_WITH(mingw-cross-compiler,
],
,)
+AC_ARG_WITH(idlc-cpp,
+ AS_HELP_STRING([--with-idlc-cpp],
+ [Specify the C Preprocessor to use for idlc.])
+ [
+ Usage: --with-idlc-cpp=cpp
+
+ Default is ucpp.
+ ]
+,)
+
AC_ARG_WITH(build-version,
AS_HELP_STRING([--with-build-version],
[Allows the builder to add a custom version tag that will appear in the
@@ -6318,13 +6328,20 @@ else
fi
AC_SUBST(BUILD_DMAKE)
-AC_MSG_CHECKING([which ucpp tp use])
-if test -n "$with_system_ucpp" -a "$with_system_ucpp" != "no"; then
- AC_MSG_RESULT([external])
- AC_PATH_PROG(SYSTEM_UCPP, ucpp)
+AC_MSG_CHECKING([which C preprocessor to use in idlc])
+if test -n "$with_idlc_cpp"; then
+ AC_MSG_RESULT([$with_idlc_cpp])
+ AC_PATH_PROG(SYSTEM_UCPP, $with_idlc_cpp)
else
- AC_MSG_RESULT([internal])
- BUILD_TYPE="$BUILD_TYPE UCPP"
+ AC_MSG_RESULT([ucpp])
+ AC_MSG_CHECKING([which ucpp tp use])
+ if test -n "$with_system_ucpp" -a "$with_system_ucpp" != "no"; then
+ AC_MSG_RESULT([external])
+ AC_PATH_PROG(SYSTEM_UCPP, ucpp)
+ else
+ AC_MSG_RESULT([internal])
+ BUILD_TYPE="$BUILD_TYPE UCPP"
+ fi
fi
AC_SUBST(SYSTEM_UCPP)