summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2011-11-08 14:19:20 +0200
committerTor Lillqvist <tlillqvist@suse.com>2011-11-08 15:04:25 +0200
commit793d4d05b580cbac56fb1537580eb2474cb8c0c5 (patch)
treec768624897f7b6d35ee0867e62d6ddbf364cb2b4 /configure.in
parent3265a628adc82d2b44df833f59ad700a8dfa4292 (diff)
Make sure we have env vars for the cross-build tools for Android
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a6b135aa820e..a6192a8f2da1 100644
--- a/configure.in
+++ b/configure.in
@@ -244,6 +244,15 @@ linux-androideabi*)
test_randr=no
test_unix_quickstarter=no
_os=Android
+
+ # Make sure env vars pointing to where to find the cross-build
+ # toolchain are set. There aren't really any sensible
+ # guesstimates.
+ for var in CC CXX AR NM OBJDUMP RANLIB STRIP; do
+ if test -z `eval echo '$'$var`; then
+ AC_MSG_ERROR([You need to set the $var environment variable in a cross-compilation for Android. See README.cross for an example.])
+ fi
+ done
;;
*)