summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2012-09-14 11:31:50 +0100
committerCaolán McNamara <caolanm@redhat.com>2012-09-17 10:46:27 +0100
commit68ffb332f5717f9ef6af11497372becddaac7ef0 (patch)
tree0b391b9749805a7a002ecb0b5a522eac20f538de /configure.in
parentc20ba023c738c0c76a07c94cb43c0a6d06f12374 (diff)
nothing propagates HAVE_CUPS_H so cups is always disabled
regression from 22f2e5f286d55cd5c1ead07fb82cd78027abf490 so, lets follow the same pattern as else where and fixup ENABLE_CUPS to be TRUE when enabled and lets just link against cups and not do the dlopen dance Change-Id: I3cff1bd98a7474c403d7ff66183e76e26e407de8
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 12 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index c90a3661fa7e..563bcdc4f64d 100644
--- a/configure.in
+++ b/configure.in
@@ -4109,32 +4109,32 @@ if test "$enable_headless" = "yes"; then
enable_gnome_vfs=no
fi
+dnl ===================================================================
dnl check for cups support
dnl ===================================================================
+ENABLE_CUPS=""
+
if test "$enable_cups" = "no"; then
test_cups=no
- ENABLE_CUPS="NO"
-elif test "$enable_cups" = "yes"; then
- if test $_os = iOS -o $_os = Android; then
- AC_MSG_ERROR([CUPS makes no sense for $_os])
- fi
- ENABLE_CUPS="YES"
-elif test $_os = iOS -o $_os = Android; then
- ENABLE_CUPS=NO
-else
- ENABLE_CUPS="YES"
fi
-AC_SUBST(ENABLE_CUPS)
+AC_MSG_CHECKING([whether to enable CUPS support])
if test "$test_cups" = "yes"; then
+ ENABLE_CUPS="TRUE"
+ AC_MSG_RESULT([yes])
+
AC_MSG_CHECKING([whether cups support is present])
AC_CHECK_LIB([cups], [cupsPrintFiles], [:])
AC_CHECK_HEADER(cups/cups.h, AC_DEFINE(HAVE_CUPS_H))
if test "$ac_cv_lib_cups_cupsPrintFiles" != "yes" -a "$ac_cv_header_cups_cups_h" != "yes"; then
- AC_MSG_ERROR([Could not find CUPS. Install libcupsys2-dev or cups???-devel.])
+ AC_MSG_ERROR([Could not find CUPS. Install libcupsys2-dev or cups-devel.])
fi
+
+else
+ AC_MSG_RESULT([no])
fi
+AC_SUBST(ENABLE_CUPS)
# fontconfig checks
if test "$test_fontconfig" = "yes"; then