summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2011-12-30 16:01:03 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2011-12-30 16:08:10 -0600
commit665386630cebe26c2e8667e359bebc7b499f4bf5 (patch)
tree41fe775c8d8befd9f0be1b8b919718f969211a49 /configure.in
parente5bbb4ea87c36e14128bb920c7c81e1de6f58d88 (diff)
move PRODUCT and PROEXT determination earlier in configure.
the is a prep work to migrate IN/OUTPATH out of set_soenv.in
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in81
1 files changed, 41 insertions, 40 deletions
diff --git a/configure.in b/configure.in
index 684277178137..27f53734dc14 100644
--- a/configure.in
+++ b/configure.in
@@ -2219,6 +2219,47 @@ printf ("hello world\n");
fi
AC_SUBST(HAVE_LD_BSYMBOLIC_FUNCTIONS)
+dnl Set the ENABLE_DBGUTIL variable
+dnl ===================================================================
+AC_MSG_CHECKING([whether to build with additional debug utilities])
+if test -n "$enable_dbgutil" && test "$enable_dbgutil" != "no"; then
+ PROEXT=""
+ PRODUCT=""
+
+ AC_MSG_RESULT([yes])
+ # cppunit and graphite expose STL in public headers
+ if test "$with_system_cppunit" = "yes"; then
+ AC_MSG_ERROR([--with-system-cppunit conflicts with DBG_UTIL build])
+ else
+ with_system_cppunit=no
+ fi
+ if test "$with_system_graphite" = "yes"; then
+ AC_MSG_ERROR([--with-system-graphite conflicts with DBG_UTIL build])
+ else
+ with_system_graphite=no
+ fi
+ if test "$with_system_mysql_cppconn" = "yes"; then
+ AC_MSG_ERROR([--with-system-mysql-cppconn conflicts with DBG_UTIL build])
+ else
+ with_system_mysql_cppconn=no
+ fi
+ if test $_os = WINNT -a \
+ \( "$enable_mozilla" != no -o \
+ "$enable_build_mozilla" != no \); then
+ # We can't build against the Mozilla stuff if using _DEBUG, will get linking errors
+ # See connectivity/drivers/mozab
+ AC_MSG_WARN([Also disabling Mozilla stuff then])
+ enable_mozilla=no
+ enable_build_mozilla=no
+ fi
+else
+ PRODUCT="full"
+ PROEXT=".pro"
+ AC_MSG_RESULT([no, full product build])
+fi
+AC_SUBST(PRODUCT)
+AC_SUBST(PROEXT)
+
dnl ===================================================================
dnl Set up a different compiler to produce tools to run on the build
dnl machine when doing cross-compilation
@@ -2427,46 +2468,6 @@ else
fi
AC_SUBST(ENABLE_DEBUG)
-dnl Set the ENABLE_DBGUTIL variable
-dnl ===================================================================
-AC_MSG_CHECKING([whether to build with additional debug utilities])
-if test -n "$enable_dbgutil" && test "$enable_dbgutil" != "no"; then
- PROEXT=""
- PRODUCT=""
-
- AC_MSG_RESULT([yes])
- # cppunit and graphite expose STL in public headers
- if test "$with_system_cppunit" = "yes"; then
- AC_MSG_ERROR([--with-system-cppunit conflicts with DBG_UTIL build])
- else
- with_system_cppunit=no
- fi
- if test "$with_system_graphite" = "yes"; then
- AC_MSG_ERROR([--with-system-graphite conflicts with DBG_UTIL build])
- else
- with_system_graphite=no
- fi
- if test "$with_system_mysql_cppconn" = "yes"; then
- AC_MSG_ERROR([--with-system-mysql-cppconn conflicts with DBG_UTIL build])
- else
- with_system_mysql_cppconn=no
- fi
- if test $_os = WINNT -a \
- \( "$enable_mozilla" != no -o \
- "$enable_build_mozilla" != no \); then
- # We can't build against the Mozilla stuff if using _DEBUG, will get linking errors
- # See connectivity/drivers/mozab
- AC_MSG_WARN([Also disabling Mozilla stuff then])
- enable_mozilla=no
- enable_build_mozilla=no
- fi
-else
- PRODUCT="full"
- PROEXT=".pro"
- AC_MSG_RESULT([no, full product build])
-fi
-AC_SUBST(PRODUCT)
-AC_SUBST(PROEXT)
dnl Determine whether to use linkoo for the smoketest installation
dnl ===================================================================