summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2011-11-11 11:57:28 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2011-11-11 11:57:28 -0600
commit6207ae5e0bca8540a5d27ccacd300099a97665cd (patch)
treeafad3225d7bcb9d0b70ad03058e78b8a8229963e /configure.in
parent7d7036c235a92268f23cc04eab8abcb08cddeb3f (diff)
nsplugin check must occurs after enable_gtk value is completely settled.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 17 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index b5d21ee91115..3d1830de6145 100644
--- a/configure.in
+++ b/configure.in
@@ -6015,23 +6015,6 @@ AC_SUBST(MOZILLA_HEADERS_CFLAGS)
AC_SUBST(SYSTEM_MOZILLA_HEADERS)
dnl ===================================================================
-dnl Check for nsplugin
-dnl ===================================================================
-AC_MSG_CHECKING([wether to build nsplugin extension])
-ENABLE_NSPLUGIN=NO
-if test "$enable_nsplugin" != "no"; then
- if test "$enable_gtk" != "no"; then
- AC_MSG_RESULT([yes])
- ENABLE_NSPLUGIN=YES
- else
- AC_MSG_RESULT([no, disabled gtk2])
- fi
-else
- AC_MSG_RESULT([no])
-fi
-AC_SUBST(ENABLE_NSPLUGIN)
-
-dnl ===================================================================
dnl Check for system sane
dnl ===================================================================
AC_MSG_CHECKING([which sane header to use])
@@ -6174,6 +6157,23 @@ if test $_os = iOS -o $_os = Android; then
enable_gtk=no
fi
+dnl ===================================================================
+dnl Check for nsplugin
+dnl ===================================================================
+AC_MSG_CHECKING([wether to build nsplugin extension])
+ENABLE_NSPLUGIN=NO
+if test "$enable_nsplugin" != "no"; then
+ if test "$enable_gtk" != "no"; then
+ AC_MSG_RESULT([yes])
+ ENABLE_NSPLUGIN=YES
+ else
+ AC_MSG_RESULT([no, disabled gtk2])
+ fi
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_NSPLUGIN)
+
dnl ***************************************
dnl testing for X libraries and includes...
dnl ***************************************