summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2011-11-03 20:10:28 +0100
committerMichael Stahl <mstahl@redhat.com>2011-11-04 10:54:58 +0100
commit30a7608b6cb95c0ba6903116101314a02b82c1dd (patch)
tree00ebc9749fb3e1ca51c984260e37daea2111aaa4 /configure.in
parent62b44c34825fc928867192f407d1d24bd5bcabca (diff)
configure: --with-linked-git: check that clone repos exist
If you specify the directory of the core repo instead of the clones subdirectory a huge mess results.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 808ec57731a3..b71a0fe6bcf7 100644
--- a/configure.in
+++ b/configure.in
@@ -2443,10 +2443,6 @@ fi
AC_SUBST(DO_FETCH_TARBALLS)
-dnl git-new-workdir
-dnl ===================================================================
-AC_SUBST(GIT_LINK_SRC)
-
dnl Disable legacy binary file formats filters
dnl ===================================================================
AC_MSG_CHECKING([whether to enable filters for legacy binary file formats (StarOffice 5.2)])
@@ -9091,6 +9087,17 @@ AC_SUBST(WITH_LANG)
AC_SUBST(WITH_LANG_LIST)
AC_SUBST(GIT_REPO_NAMES)
+dnl git-new-workdir
+dnl ===================================================================
+if test -n "${GIT_LINK_SRC}"; then
+ for repo in ${GIT_REPO_NAMES}; do
+ if ! test -d "${GIT_LINK_SRC}"/${repo}; then
+ AC_MSG_ERROR([linked git: required repository does not exist: ${GIT_LINK_SRC}/${repo}])
+ fi
+ done
+fi
+AC_SUBST(GIT_LINK_SRC)
+
AC_MSG_CHECKING([for another 'intro' bitmap])
INTRO_BITMAP=
if test -z "$with_intro_bitmap" -o "$with_intro_bitmap" = "no" ; then