summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPedro Giffuni <pfg@apache.org>2011-11-27 04:05:18 +0000
committerPedro Giffuni <pfg@apache.org>2011-11-27 04:05:18 +0000
commit0a48af86063bad76d61c45b130cf853c23d8a6d0 (patch)
tree22d1bfdf420e25071916275a87e3c613fb09c795 /configure.in
parent918fac05ccea5711f16fd6d089860834cbcc9e1a (diff)
Remove the Anti-Grain Geometry agg module: the OpenGL canvas rendering code was never really completed.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in58
1 files changed, 0 insertions, 58 deletions
diff --git a/configure.in b/configure.in
index 5ed517d2a971..36a04d8e037a 100644
--- a/configure.in
+++ b/configure.in
@@ -29,9 +29,6 @@ AC_ARG_WITH(dmake-url,
AC_ARG_WITH(gnu-patch,
[ --with-gnu-patch Specify location of GNU patch on Solaris or FreeBSD
],,)
-AC_ARG_ENABLE(agg,
-[ --enable-agg Use internal agg
-],,)
AC_ARG_WITH(gnu-cp,
[ --with-gnu-cp Specify location of GNU cp on Solaris or FreeBSD
],,)
@@ -549,9 +546,6 @@ AC_ARG_ENABLE(Xaw,
AC_ARG_WITH(system-neon,
[ --with-system-neon Use neon already on system
],,)
-AC_ARG_WITH(system-agg,
-[ --with-system-agg Use AGG already on system
-],,)
AC_ARG_ENABLE(hunspell,
[ --enable-hunspell Determines whether to enable the Hunspell library.
If enabled, the library will be built unless you
@@ -5122,58 +5116,6 @@ AC_SUBST(OPENSSL_CFLAGS)
AC_SUBST(OPENSSL_LIBS)
dnl ===================================================================
-dnl Test for enabling agg
-dnl ===================================================================
-AC_MSG_CHECKING([whether to enable agg])
-if test "$enable_agg" = "yes"; then
- AC_MSG_RESULT([yes])
- AC_SUBST(ENABLE_AGG)
- ENABLE_AGG=YES
- AGG_VERSION=2400
-else
- AC_MSG_RESULT([no])
- ENABLE_AGG=NO
-
- dnl ===================================================================
- dnl Check for system AGG
- dnl ===================================================================
- AC_MSG_CHECKING([which AGG to use])
- if test -n "$with_system_agg" -o -n "$with_system_libs" && \
- test "$with_system_agg" != "no"; then
- AC_MSG_RESULT([external])
- PKG_CHECK_MODULES(AGG, libagg >= 2.3)
- AC_MSG_CHECKING([agg version])
- # workaround; if AGG_CFLAGS is empty (broken libagg.pc in 2.3), add /usr/include/agg2 anyway
- # (/usr/include gets stripped from pkg-config output)
- if test -z "$AGG_CFLAGS" || test "$AGG_CFLAGS" = " "; then
- AGG_INCDIR="`$PKG_CONFIG --variable includedir libagg`/agg2"
- else
- AGG_INCDIR="`echo $AGG_CFLAGS | $SED -e s/-I//`"
- fi
- if $PKG_CONFIG --modversion libagg | grep -q 2.3 || \
- $PKG_CONFIG --modversion libagg | grep -q 2.4; then
- # 2.4's libagg.pc.in still contains 2.3 :/
- if $EGREP -q "Version 2.4" `echo $AGG_INCDIR`/agg_basics.h; then
- AC_MSG_RESULT([2.4])
- AGG_VERSION=2400
- else
- AC_MSG_RESULT([2.3])
- AGG_VERSION=2300
- fi
- SYSTEM_AGG=YES
- else
- AC_MSG_ERROR([only agg 2.3 and 2.4 are supported])
- fi
- else
- AC_MSG_RESULT([internal])
- SYSTEM_AGG=NO
- BUILD_TYPE="$BUILD_TYPE AGG"
- fi
- AC_SUBST(SYSTEM_AGG)
- AC_SUBST(AGG_VERSION)
-fi
-
-dnl ===================================================================
dnl Check for system redland
dnl ===================================================================
AC_MSG_CHECKING([which redland library to use])