summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichal Kubecek <mkubecek@suse.cz>2016-06-02 08:12:37 +0200
committerjan iversen <jani@documentfoundation.org>2016-06-03 05:42:09 +0000
commite5d48f12faec6027bf79411cb69111d90f4e4129 (patch)
tree3ba19a8247e85788c02d31a1407d0d0ef83ab7bf /configure.ac
parent64e83932264f0d708e4ce2dce9b36a933afd2fbf (diff)
configure.ac: allow build with Firebird 3.0
Relax the checks in configure.ac to allow building against recently released Firebird 3.0. In this version, libfbclient is also used to access local database files (embedded server mode) rather than separate libfbembed. Change-Id: Id498cbca22409f95ee299a6165cc765efa25eca7 Reviewed-on: https://gerrit.libreoffice.org/25845 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: jan iversen <jani@documentfoundation.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 9 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 442a8169ebaf..0c4b67729a2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8657,8 +8657,10 @@ if test "$enable_firebird_sdbc" = "yes" ; then
AC_PATH_PROG(FIREBIRDCONFIG, [fb_config])
if test -z "$FIREBIRDCONFIG"; then
AC_MSG_NOTICE([No fb_config -- using pkg-config])
- PKG_CHECK_MODULES(FIREBIRD, fbembed)
- FIREBIRD_VERSION=`pkg-config --modversion fbembed`
+ PKG_CHECK_MODULES([FIREBIRD], [fbclient >= 3], [FIREBIRD_PKGNAME=fbclient], [
+ PKG_CHECK_MODULES([FIREBIRD], [fbembed], [FIREBIRD_PKGNAME=fbembed])
+ ])
+ FIREBIRD_VERSION=`pkg-config --modversion "$FIREBIRD_PKGNAME"`
else
AC_MSG_NOTICE([fb_config found])
FIREBIRD_VERSION=`$FIREBIRDCONFIG --version`
@@ -8673,19 +8675,20 @@ if test "$enable_firebird_sdbc" = "yes" ; then
if test -n "${FIREBIRD_VERSION}"; then
FIREBIRD_MAJOR=`echo $FIREBIRD_VERSION | cut -d"." -f1`
FIREBIRD_MINOR=`echo $FIREBIRD_VERSION | cut -d"." -f2`
- if test "$FIREBIRD_MAJOR" -eq "2" -a "$FIREBIRD_MINOR" -eq "5"; then
+ if test "$FIREBIRD_MAJOR" -eq "2" -a "$FIREBIRD_MINOR" -eq "5" -o \
+ "$FIREBIRD_MAJOR" -eq "3" -a "$FIREBIRD_MINOR" -eq "0"; then
AC_MSG_RESULT([OK])
else
- AC_MSG_ERROR([Ensure firebird 2.5.x is installed])
+ AC_MSG_ERROR([Ensure firebird 2.5.x or 3.0.x is installed])
fi
else
__save_CFLAGS="${CFLAGS}"
CFLAGS="${CFLAGS} ${FIREBIRD_CFLAGS}"
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[#include <ibase.h>
-#if defined(FB_API_VER) && FB_API_VER == 25
+#if defined(FB_API_VER) && (FB_API_VER == 25 || FB_API_VER == 30)
#else
#error "Wrong Firebird API version"
-#endif]])],AC_MSG_RESULT([OK]),AC_MSG_ERROR([Ensure firebird 2.5.x is installed]))
+#endif]])],AC_MSG_RESULT([OK]),AC_MSG_ERROR([Ensure firebird 2.5.x or 3.0.x is installed]))
CFLAGS="${__save_CFLAGS}"
fi
ENABLE_FIREBIRD_SDBC="TRUE"