summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2017-03-14 11:59:12 +0200
committerTor Lillqvist <tml@collabora.com>2017-03-14 21:41:26 +0000
commite597ef0489d9d5504721d21eefa15c65da0fb240 (patch)
tree7c9e6e1034830b909c155568f17ecb80c9a41322 /configure.ac
parent3fa34da687ba4be98319888a90cba6414b9f3fbe (diff)
No need for --disable-activex and --disable-atl any longer
Change-Id: I7ac4f32cb01bfcc3a2c06e69280c2150d408ec6b Reviewed-on: https://gerrit.libreoffice.org/35174 Reviewed-by: David Ostrovsky <david@ostrovsky.org> Reviewed-by: Tor Lillqvist <tml@collabora.com> Tested-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 0 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 6b35424f4af0..92760129ede1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1130,16 +1130,6 @@ libo_FUZZ_ARG_ENABLE(directx,
compile. (DirectX SDK, GDI+ libs)])
)
-libo_FUZZ_ARG_ENABLE(activex,
- AS_HELP_STRING([--disable-activex],
- [Disable the use of ActiveX for a Windows build.])
-,)
-
-libo_FUZZ_ARG_ENABLE(atl,
- AS_HELP_STRING([--disable-atl],
- [Disable the use of ATL for a Windows build.])
-,)
-
libo_FUZZ_ARG_ENABLE(avahi,
AS_HELP_STRING([--enable-avahi],
[Determines whether to use Avahi to advertise Impress to remote controls.]),
@@ -3698,34 +3688,11 @@ if test "$_os" = "WINNT"; then
ENABLE_DIRECTX=""
AC_MSG_RESULT([no])
fi
-
- AC_MSG_CHECKING([whether to use ActiveX])
- if test "$enable_activex" = "yes" -o "$enable_activex" = ""; then
- DISABLE_ACTIVEX=""
- AC_MSG_RESULT([yes])
- else
- DISABLE_ACTIVEX="TRUE"
- AC_MSG_RESULT([no])
- fi
-
- AC_MSG_CHECKING([whether to use ATL])
- if test "$enable_atl" = "yes" -o "$enable_atl" = ""; then
- DISABLE_ATL=""
- AC_DEFINE(HAVE_FEATURE_ATL, 1)
- AC_MSG_RESULT([yes])
- else
- DISABLE_ATL="TRUE"
- AC_MSG_RESULT([no])
- fi
else
ENABLE_DIRECTX=""
- DISABLE_ACTIVEX="TRUE"
- DISABLE_ATL="TRUE"
fi
AC_SUBST(ENABLE_DIRECTX)
-AC_SUBST(DISABLE_ACTIVEX)
-AC_SUBST(DISABLE_ATL)
#
# unowinreg.dll