summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2015-06-29 17:34:30 +0200
committerJan Holesovsky <kendy@collabora.com>2015-06-29 17:43:31 +0200
commite03a5f5e8303668cb68844b6df9ec53a561792bc (patch)
tree3424fadf42fb83b06ff16e47c3d832e57a783241 /configure.ac
parent8c07510faa32211536a1d3c461b674812b025bdd (diff)
online update: Configure switch --enable-online-update=mar
This will enable the mar-based online update instead of the 'traditional' one. At the moment, this does not build, as libbz2 was not packaged as an external library yet. Change-Id: I1ad7d9adf7a12a427786682ad932597eb2319256
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4afc1d413b31..aecbe8fc0406 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1342,7 +1342,9 @@ AC_ARG_ENABLE(extra-font,
AC_ARG_ENABLE(online-update,
AS_HELP_STRING([--enable-online-update],
[Enable the online update service that will check for new versions of
- LibreOffice. By default, it is enabled on Windows and Mac, disabled on Linux.]),
+ LibreOffice. By default, it is enabled on Windows and Mac, disabled on Linux.
+ If the value is "mar", the experimental Mozilla-like update will be
+ enabled instead of the traditional update mechanism.]),
,)
AC_ARG_ENABLE(extension-update,
@@ -11782,6 +11784,7 @@ dnl Test whether to enable online update service
dnl ===================================================================
AC_MSG_CHECKING([whether to enable online update])
ENABLE_ONLINE_UPDATE=
+ENABLE_ONLINE_UPDATE_MAR=
if test "$enable_online_update" = ""; then
if test "$_os" = "WINNT" -o "$_os" = "Darwin"; then
AC_MSG_RESULT([yes])
@@ -11790,7 +11793,10 @@ if test "$enable_online_update" = ""; then
AC_MSG_RESULT([no])
fi
else
- if test "$enable_online_update" = "yes"; then
+ if test "$enable_online_update" = "mar"; then
+ AC_MSG_RESULT([yes - MAR-based online update])
+ ENABLE_ONLINE_UPDATE_MAR="TRUE"
+ elif test "$enable_online_update" = "yes"; then
AC_MSG_RESULT([yes])
ENABLE_ONLINE_UPDATE="TRUE"
else
@@ -11798,6 +11804,7 @@ else
fi
fi
AC_SUBST(ENABLE_ONLINE_UPDATE)
+AC_SUBST(ENABLE_ONLINE_UPDATE_MAR)
dnl ===================================================================
dnl Test whether to enable extension update