summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2012-12-06 14:59:42 +0100
committerStephan Bergmann <sbergman@redhat.com>2012-12-06 14:59:42 +0100
commitde2c6007fc584150210eb29d15044fca0d8321f7 (patch)
tree2546f16456e75d135f262f52a149ade4b0251717 /configure.ac
parent43137f06505324b73ff66420c63e40b37a8d0618 (diff)
Do not accumulate warnings across configure runs
...and remove temporary file again. Change-Id: I199b054d8e7b87d1c9268abbe628393d480e42f7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index eb2389d07f5d..1e80d4fdd40a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,11 +49,12 @@ PathFormat()
fi
}
+rm -f warn
have_WARNINGS="no"
add_warning()
{
if test "$have_WARNINGS" = "no"; then
- echo "*************************************" >> warn
+ echo "*************************************" > warn
have_WARNINGS="yes"
if which tput >/dev/null 2>/dev/null && test `tput colors` -ge 8; then
dnl <esc> as actual byte (U+1b), [ escaped using quadrigraph @<:@
@@ -12492,7 +12493,8 @@ _EOF
fi
if test -f warn; then
- cat warn
+ cat warn
+ rm warn
fi
dnl vim:set shiftwidth=4 softtabstop=4 expandtab: