summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@collabora.com>2014-02-25 21:47:33 +0100
committerMatúš Kukan <matus.kukan@collabora.com>2014-03-06 12:36:22 +0100
commitdcae0509135c2067635ae3cf84b05dc9fb3d2d02 (patch)
treebf27a61ace258b814b37e3cfc9980e047e9f4d4c /configure.ac
parent0b27253aff771e104a9fd5d17595b205b2fc39fd (diff)
Build webdav based on serf if neon is disabled.
Change-Id: I0cbb89c8d5ac65eda8bb21aaf0d07996a015d281
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac52
1 files changed, 32 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 6c78067acb95..cdae8b5cb983 100644
--- a/configure.ac
+++ b/configure.ac
@@ -652,7 +652,6 @@ linux-android*)
build_gstreamer=no
build_gstreamer_0_10=no
enable_lotuswordpro=no
- enable_neon=no
enable_mpl_subset=yes
enable_opengl=no
enable_report_builder=no
@@ -1777,6 +1776,14 @@ AC_ARG_WITH(lpsolver,
WITH_LPSOLVER=$withval,
WITH_LPSOLVER="lpsolve")
+AC_ARG_WITH(webdav,
+ AS_HELP_STRING([--with-webdav],
+ [Specify which library to use for webdav implementation.
+ Possible values: "neon", "serf", "no". The default value is "neon".
+ Example: --with-webdav="serf"]),
+ WITH_WEBDAV=$withval,
+ WITH_WEBDAV="neon")
+
AC_ARG_WITH(linker-hash-style,
AS_HELP_STRING([--with-linker-hash-style],
[Use linker with --hash-style=<style> when linking shared objects.
@@ -7333,7 +7340,6 @@ if test $_os = iOS; then
enable_lotuswordpro=no
enable_postgresql_sdbc=no
enable_lotuswordpro=no
- enable_neon=no
enable_extension_integration=no
enable_report_builder=no
with_theme="tango"
@@ -9156,15 +9162,16 @@ AC_SUBST(XRANDR_CFLAGS)
AC_SUBST(XRANDR_LIBS)
AC_SUBST(ENABLE_RANDR)
-dnl ===================================================================
-dnl Check for building neon
-dnl ===================================================================
-AC_MSG_CHECKING([whether to use neon])
-if test "$enable_neon" = "no"; then
- AC_MSG_RESULT([no])
- DISABLE_NEON=TRUE
- AC_SUBST(DISABLE_NEON)
-
+if test "$enable_neon" = "no" -o "$enable_mpl_subset" = "yes"; then
+ WITH_WEBDAV="serf"
+fi
+if test $_os = iOS -o $_os = Android; then
+ WITH_WEBDAV="no"
+fi
+AC_MSG_CHECKING([for webdav library])
+case "$WITH_WEBDAV" in
+serf)
+ AC_MSG_RESULT([serf])
# Check for system apr-util
libo_CHECK_SYSTEM_MODULE([apr],[APR],[apr-util-1],
["-I${WORKDIR}/UnpackedTarball/apr/include -I${WORKDIR}/UnpackedTarball/apr_util/include"],
@@ -9179,11 +9186,10 @@ if test "$enable_neon" = "no"; then
if test "$COM" = "MSC"; then
SERF_LIBS="${WORKDIR}/UnpackedTarball/serf/Release/serf-1.lib"
fi
-else
- AC_MSG_RESULT([yes])
- dnl ===================================================================
- dnl Check for system neon
- dnl ===================================================================
+ ;;
+neon)
+ AC_MSG_RESULT([neon])
+ # Check for system neon
libo_CHECK_SYSTEM_MODULE([neon],[NEON],[neon >= 0.26.0])
if test "$with_system_neon" = "yes"; then
NEON_VERSION="`$PKG_CONFIG --modversion neon | $SED 's/\.//g'`"
@@ -9194,7 +9200,13 @@ else
NEON_VERSION=0295
fi
AC_SUBST(NEON_VERSION)
-fi
+ ;;
+*)
+ AC_MSG_RESULT([none, disabled])
+ WITH_WEBDAV=""
+ ;;
+esac
+AC_SUBST(WITH_WEBDAV)
dnl ===================================================================
dnl Check for disabling cve_tests
@@ -9257,7 +9269,7 @@ dnl ===================================================================
dnl Check for building gnutls
dnl ===================================================================
AC_MSG_CHECKING([whether to use gnutls])
-if test "$enable_neon" != "no" && test "$enable_openssl" = "no"; then
+if test "$WITH_WEBDAV" = "neon" && test "$enable_openssl" = "no"; then
AC_MSG_RESULT([yes])
AM_PATH_LIBGCRYPT()
PKG_CHECK_MODULES(GNUTLS, [gnutls],,
@@ -12481,8 +12493,8 @@ if test "$enable_mpl_subset" = "yes"; then
if test "$enable_lotuswordpro" = "yes"; then
AC_MSG_ERROR([need to --disable-lotuswordpro - a Lotus Word Pro file format import filter.])
fi
- if test "$enable_neon" != "no" -o "x$DISABLE_NEON" != "xTRUE"; then
- AC_MSG_ERROR([need to --disable-neon - webdav support.])
+ if test "$WITH_WEBDAV" = "neon"; then
+ AC_MSG_ERROR([need --with-webdav=serf or --without-webdav - webdav support.])
fi
if test "x$enable_ext_mariadb_connector" = "xyes"; then
AC_MSG_ERROR([need to --disable-ext-mariadb-connector - mariadb/mysql support.])