summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrzej J.R. Hunt <andrzej@ahunt.org>2013-07-12 12:52:17 +0100
committerAndrzej J.R. Hunt <andrzej@ahunt.org>2013-07-16 16:40:14 +0200
commitdc2e845dfe45e1ec1f65012b14772ad7afd87cce (patch)
treec39277dae33f00e974df32d6dd53a822426884db /configure.ac
parentc3ed455e0462faf5ca36d19d310ebda4222cede1 (diff)
Enable firebird by default, disable as default embedded driver.
Change-Id: I4907b8b7a3b9ab767132d35b5c3539d52d122660
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 3 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 5615d25e63fc..a08fafea1ed3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1170,10 +1170,10 @@ AC_ARG_ENABLE(lotuswordpro,
,enable_lotuswordpro=yes)
AC_ARG_ENABLE(firebird-sdbc,
- AS_HELP_STRING([--enable-firebird-sdbc],
+ AS_HELP_STRING([--disable-firebird-sdbc],
[Enable the build of the Firebird-SDBC driver. Work in progress,
use only if you are hacking on it.]),
-,enable_firebird_sdbc=no)
+,enable_firebird_sdbc=yes)
AC_ARG_ENABLE(coretext,
AS_HELP_STRING([--enable-coretext],
@@ -1447,17 +1447,6 @@ AC_ARG_WITH(system-firebird,
driver. If fb_config is not in PATH, use FBCONFIG to point to it.]),,
[with_system_firebird="$with_system_libs"])
-# To be replaced with IBPP, in case we want ot use it
-dnl AC_ARG_WITH(libibpp-path,
-dnl AS_HELP_STRING([--with-libibpp-path],
-dnl [Use this Firebird C++ API (libibpp) installation for building
-dnl the Firebird-SDBC extension.])
-dnl [
-dnl Usage: --with-libibpp-path=<absolute path to
-dnl your libibpp installation>
-dnl ],
-dnl ,)
-
AC_ARG_WITH(system-hsqldb,
AS_HELP_STRING([--with-system-hsqldb],
[Use hsqldb already on system.]))
@@ -8106,7 +8095,7 @@ dnl ===================================================================
dnl Check for Firebird stuff
dnl ===================================================================
ENABLE_FIREBIRD_SDBC=""
-if test "x$enable_firebird_sdbc" != "xno"; then
+if test "x$enable_firebird_sdbc" = "xyes"; then
SCPDEFS="$SCPDEFS -DWITH_FIREBIRD_SDBC"