summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2015-10-29 15:37:45 +0100
committerAndras Timar <andras.timar@collabora.com>2016-06-11 12:52:37 +0200
commitdba11c86ac4bda84e2989a0463cea7d61e5a8e10 (patch)
tree181502b1f91722727117ff29f99cf58885c5be13 /configure.ac
parent9ea41d8f915491653df47064edafda47a987fe80 (diff)
OSX issues with space in product name
(cherry picked from commit 79f3a7bfefb8decd2d18df21d799f2d9241a44c3) Change-Id: I0155372c8e5cd0eb91bfbea304190502cbf32e3c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fdc8927648c0..bb5711694aa5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -708,11 +708,12 @@ darwin*) # Mac OS X or iOS
test_cups=no
else
_os=Darwin
+ ONEWORDPRODUCTNAME=`echo "${PRODUCTNAME// /}"`
if test -n "$LODE_HOME" ; then
mac_sanitize_path
AC_MSG_NOTICE([sanitized the PATH to $PATH])
fi
- INSTROOTSUFFIX=/$PRODUCTNAME.app/Contents
+ INSTROOTSUFFIX=/$ONEWORDPRODUCTNAME.app/Contents
SDKDIRNAME=AC_PACKAGE_NAME${PRODUCTVERSION}_SDK
fi
enable_systray=no
@@ -12414,7 +12415,7 @@ else
fi
AC_SUBST(WITH_COMPAT_OOWRAPPERS)
-INSTALLDIRNAME=`echo AC_PACKAGE_NAME | $AWK '{print tolower($0)}'`
+INSTALLDIRNAME=`echo AC_PACKAGE_NAME | $AWK '{gsub(" ", "", $0);print tolower($0)}'`
AC_MSG_CHECKING([for install dirname])
if test -n "$with_install_dirname" -a "$with_install_dirname" != "no" -a "$with_install_dirname" != "yes"; then
INSTALLDIRNAME="$with_install_dirname"