summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2014-08-06 00:03:21 +0200
committerRene Engelhard <rene@debian.org>2014-08-06 00:03:21 +0200
commitd85f513934bb5735a2c0c343fbe7dc2b9c11af3e (patch)
treed87cdad5e89f5d631d903388d242f0ffc635be27 /configure.ac
parent6e93ea106e7444980532b090deacdf6eb7397aed (diff)
implement --with-system-coinmp
Change-Id: I02928097f049e8f3cbefbc872b570b2d2b072658
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e91773f61276..3aadd12fa02b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1867,6 +1867,11 @@ AC_ARG_WITH(system-lpsolve,
[Use lpsolve already on system.]),,
[with_system_lpsolve="$with_system_libs"])
+AC_ARG_WITH(system-coinmp,
+ AS_HELP_STRING([--with-system-coinmp],
+ [Use CoinMP already on system.]),,
+ [with_system_coinmp="$with_system_libs"])
+
AC_ARG_WITH(system-liblangtag,
AS_HELP_STRING([--with-system-liblangtag],
[Use liblangtag library already on system.]),,
@@ -9661,12 +9666,19 @@ AC_MSG_CHECKING([whether to build with CoinMP])
if test "$enable_coinmp" != "no"; then
ENABLE_COINMP=TRUE
AC_MSG_RESULT([yes])
- # Should we check for system CoinMP ? How to do that ?
- BUILD_TYPE="$BUILD_TYPE COINMP"
+ if test "$with_system_coinmp" = "yes"; then
+ SYSTEM_COINMP=TRUE
+ PKG_CHECK_MODULES( COINMP, coinmp )
+ else
+ BUILD_TYPE="$BUILD_TYPE COINMP"
+ fi
else
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_COINMP)
+AC_SUBST(SYSTEM_COINMP)
+AC_SUBST(COINMP_CFLAGS)
+AC_SUBST(COINMP_LIBS)
ENABLE_LPSOLVE=
AC_MSG_CHECKING([whether to build with lpsolve])