summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbrainbreaker <gautamprajapati06@gmail.com>2017-06-22 22:49:38 +0530
committerMiklos Vajna <vmiklos@collabora.co.uk>2017-07-11 16:49:46 +0200
commitd81cf50a6fe2d4d03b9056679758a14404a03f12 (patch)
tree1641e2e1af10998176464776e66584aecaded8da /configure.ac
parentc5cb46b45b69b03e5a6735b9c59bf686069ad401 (diff)
android: update configure.ac for supporting Clang5.0
Change-Id: Ia99f3b4a8c9aba506938b8c3669c74b5dc1b4c16 Reviewed-on: https://gerrit.libreoffice.org/39122 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Miklos Vajna <vmiklos@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5d34221b7232..5fa82f7cbb8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -420,9 +420,9 @@ if test -n "$with_android_ndk"; then
ANDROID_BINUTILS_DIR=$ANDROID_NDK_HOME/toolchains/$android_platform_prefix-$with_android_ndk_toolchain_version
ANDROID_COMPILER_DIR=$ANDROID_BINUTILS_DIR
;;
- clang3.3|clang3.4)
- ANDROID_BINUTILS_DIR=$ANDROID_NDK_HOME/toolchains/$android_platform_prefix-4.8
- ANDROID_COMPILER_DIR=$ANDROID_NDK_HOME/toolchains/llvm-${with_android_ndk_toolchain_version#clang}
+ clang3.3|clang3.4|clang5.0)
+ ANDROID_BINUTILS_DIR=$ANDROID_NDK_HOME/toolchains/$android_platform_prefix-4.9
+ ANDROID_COMPILER_DIR=$ANDROID_NDK_HOME/toolchains/llvm
ANDROID_USING_CLANG=true
;;
*)
@@ -474,7 +474,7 @@ if test -n "$with_android_ndk"; then
# as is the case when using the ndk-bundle as installed with android studio
ANDROID_NDK_TOOLCHAIN_VERSION_SUBDIR="${with_android_ndk_toolchain_version}/"
if test -n "$ANDROID_USING_CLANG"; then
- ANDROID_NDK_TOOLCHAIN_VERSION_SUBDIR=4.8/
+ ANDROID_NDK_TOOLCHAIN_VERSION_SUBDIR=4.9/
fi
fi