summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-05-16 13:33:00 +0300
committerTor Lillqvist <tml@iki.fi>2013-05-16 13:34:29 +0300
commitd1a5da152a6814a4ee00fd04a2c682cc582e063a (patch)
tree426c3a75313f285aced3d940ba7592b205eb2832 /configure.ac
parentc6d8cd5f48b3097d8f085318ab86e502f8d4ca15 (diff)
Handle --enable-macosx-code-signing=no properly
Change-Id: Ib080d0317ea0c34e12db27f6ed080b3928cb165d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cbd7c79773b7..565aef947f2a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2598,7 +2598,7 @@ if test "$_os" = "Darwin"; then
pretty_name=`security find-identity -p codesigning -v | grep "$MACOSX_CODESIGNING_IDENTITY" | sed -e 's/^[[^"]]*"//' -e 's/"//'`
AC_MSG_RESULT([yes, using the identity $MACOSX_CODESIGNING_IDENTITY for $pretty_name])
fi
- elif test -n "$enable_macosx_code_signing"; then
+ elif test -n "$enable_macosx_code_signing" -a "$enable_macosx_code_signing" != no ; then
MACOSX_CODESIGNING_IDENTITY=$enable_macosx_code_signing
pretty_name=`security find-identity -p codesigning -v | grep "$MACOSX_CODESIGNING_IDENTITY" | sed -e 's/^[[^"]]*"//' -e 's/"//'`
AC_MSG_RESULT([yes, using the identity $MACOSX_CODESIGNING_IDENTITY for $pretty_name])