summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-05-16 15:58:27 +0200
committerMichael Stahl <mstahl@redhat.com>2013-05-16 16:17:29 +0200
commitcdc87e5f32056da77749304f3148f1c842a958d0 (patch)
tree7f0de5162ed8eea38c05f83a6718d6eb2c00e86c /configure.ac
parenta1dff2901e9b6f70ea87df5e76825367b38ceaf4 (diff)
configure: tweak the jpeg error messages a bit
Apparently libjpeg-turbo (used on Fedora) has a bunch of emulation modes for jpeg-6/jpeg-7/jpeg-8 compatibility, and the jpeg-6 one supports JERR_BAD_CROP_SPEC too, which was added to libjpeg in jpeg-7. Change-Id: I5ca4deb3ea059996cf72e0e92fc80bd11fc6979a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 556f94627e28..12d950bf8e89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7135,7 +7135,7 @@ if test "$with_system_jpeg" = "yes"; then
[AC_MSG_ERROR(jpeg.h not found. install libjpeg)], [])
AC_CHECK_LIB(jpeg, jpeg_resync_to_restart, [ JPEG3RDLIB=-ljpeg ],
[AC_MSG_CHECKING(jpeg library not found or fuctional)], [])
- AC_MSG_CHECKING([[libjpeg version is 7 or greater]])
+ AC_MSG_CHECKING([[libjpeg supports JERR_BAD_CROP_SPEC (jpeg-7 API)]])
AC_COMPILE_IFELSE([ AC_LANG_SOURCE(
[[
#include <stdio.h>
@@ -7144,7 +7144,7 @@ int main(int c, char**v) { printf("%d\n", JERR_BAD_CROP_SPEC); return 0; }
]]) ],
[AC_MSG_RESULT(yes)],
[AC_MSG_RESULT(no)
- AC_MSG_ERROR(jpeg library version >= 7 required)
+ AC_MSG_ERROR(jpeg library version >= 7 or jpeg-turbo version >= 1.1 required)
])
libo_MINGW_CHECK_DLL([libjpeg])
else